Network Problems

Issues related to configuring your network
Post Reply
DANNDP
Posts: 22
Joined: 2009/11/26 21:24:53
Contact:

Network Problems

Post by DANNDP » 2010/02/08 05:39:46

Hello my friends,

I'm having some problems in one of my Centos servers; i'm using Asterisk (an IP-PBX) and the PBX shows me that i'm having some network problems, asterisk experts tell me that the problem could be located in the eth port of the server or in the switch of the network...

Is there any command or procedure to check the status of the network ports on a Centos Server? what should i do first? is there any software to help me check my network? or may be stress the network with some application to check if the eht port goes down, that would be my guests....i hope you can help me

Best Regards

DD

User avatar
AlanBartlett
Forum Moderator
Posts: 9320
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Network Problems

Post by AlanBartlett » 2010/02/08 15:35:25

Not being an "in-depth" networking person, I'll suggest that the first thing is to take a look at the output returned by an [i]ifconfig[/i] command.

Example: This is what I see --

[code]
$ /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:4F:24:66:81
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:4fff:fe24:6681/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:44605 errors:0 dropped:0 overruns:1 frame:0
TX packets:29107 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:42412551 (40.4 MiB) TX bytes:10049743 (9.5 MiB)
Interrupt:11 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:54 errors:0 dropped:0 overruns:0 frame:0
TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6452 (6.3 KiB) TX bytes:6452 (6.3 KiB)
[/code]
Check for any errors on the [i]RX[/i] & [i]TX packets[/i] lines.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Network Problems

Post by gerald_clark » 2010/02/08 15:40:50

Please show the output of uname -a.
If you are running an out-if-the-box PBX package, you may not have a CentOS kernel.

DANNDP
Posts: 22
Joined: 2009/11/26 21:24:53
Contact:

Re: Network Problems

Post by DANNDP » 2010/02/09 18:18:47

Thanks for the answer,

Following you will see my ifconfign output, seems to be OK:

[root@localhost ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:21:5E:73:0E:40
inet addr:10.4.1.6 Bcast:10.4.1.15 Mask:255.255.255.240
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6797176 errors:0 dropped:0 overruns:0 frame:0
TX packets:8007127 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
Interrupt:169 Memory:ce000000-ce012100

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:387756 errors:0 dropped:0 overruns:0 frame:0
TX packets:387756 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0

w1g1 Link encap:Point-to-Point Protocol
UP POINTOPOINT RUNNING NOARP MTU:8 Metric:1
RX packets:337180075 errors:0 dropped:0 overruns:0 frame:0
TX packets:337180075 errors:0 dropped:0 overruns:0 carrier:1089
collisions:0 txqueuelen:100
Interrupt:217 Memory:f8ca0000-f8ca1fff

w2g1 Link encap:Point-to-Point Protocol
UP POINTOPOINT NOARP MTU:8 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:338336
collisions:0 txqueuelen:100
Interrupt:217 Memory:f8ca0000-f8ca1fff

What should i check now my friend?

DANNDP
Posts: 22
Joined: 2009/11/26 21:24:53
Contact:

Re: Network Problems

Post by DANNDP » 2010/02/09 18:29:25

Thanks my friend,

Following the output from uname -a

[root@localhost ~]# uname -a
Linux localhost 2.6.9-89.ELsmp #1 SMP Mon Jun 22 12:32:43 EDT 2009 i686 i686 i386 GNU/Linux

Thanks in advance for your help my friend

Best Regards

DD

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Network Problems

Post by gerald_clark » 2010/02/09 18:41:19

Ifconfig shows no errors.
What exactly is the problem supposed to be?
Have you tried new cable, port, switch?

what does route -n show?
You really have not supplied enough information to know where to start looking.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Network Problems

Post by pschaff » 2010/02/09 18:54:49

You should consider updating - that's an old kernel. Current is kernel-smp-2.6.9-89.0.20.EL.

DANNDP
Posts: 22
Joined: 2009/11/26 21:24:53
Contact:

Re: Network Problems

Post by DANNDP » 2010/02/16 20:00:56

My problem is that i have an asterisk pbx running on centos 4.8, my problem is that asterisk stop working and asterisk's experts say that the problem is in the network, so im checking just to be sure...here is the output that you told me to do my friend:

[root@localhost asterisk]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.4.1.0 0.0.0.0 255.255.255.240 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 10.4.1.1 0.0.0.0 UG 0 0 0 eth0

DrLove73
Posts: 70
Joined: 2009/03/14 12:12:06
Location: Serbia
Contact:

Re: Network Problems

Post by DrLove73 » 2010/02/17 00:09:11

Any recent changes to network topology or system updates prior to "network " failure? added some boxes, removed some, messed with LAN cables and/or switches?

Have you tried to power down all the switches for short period of time (2 minutes)?
Have you tried to ping remote hosts from server?

Post Reply