Shorewall Multi-ISP Supprt

Issues related to configuring your network
onebyte
Posts: 9
Joined: 2009/05/05 10:29:39
Contact:

Shorewall Multi-ISP Supprt

Postby onebyte » 2010/09/30 20:37:59

First off, apologies if this is in the wrong forum. Although I'm having a problem with Shorewall, I'm pretty sure the problem is with the distro and more specifically the kernel setup.

I have 6 CentOS 5.x boxes using various hardware from HP Proliant servers down to a couple of Fabiatech embedded system running as firewalls using Shorewall to configure iptables and all using multiple WAN links. In all cases I can route traffic at will down the different WAN interfaces.

My problem now is I have a couple of AMD Geode LX-800 based devices that CentOS 5.x just will not install on due to CPU support from what I can tell. My only option seems to have been to install CentOS 4.x, in this case 4.8. I've copied across my normal configuration but I just cannot get traffic to route down the second NIC. I know the configuration of Shorewall is good as the exact same configuration is running on all these other boxes and one of the boxes has 6 WAN interfaces so I know the Shorewall side is good.

I'm guessing that there must be a kernel setting or module that isn't correct. I know that the 4.8 box doesn't support hi-marks in the providers file but other than that I can't work out where the problem is.

Please can someone help?

Please let me know what config details you want me to post and I'll put them up?

Thanks in advance.

Simon