Upgrading CentOS4 LAMP server

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
MickKi
Posts: 6
Joined: 2008/11/30 21:37:11

Upgrading CentOS4 LAMP server

Post by MickKi » 2009/03/30 10:12:08

Hi All,

I am trying to upgrade a CentOS 4 installation. I followed the Web Stack instructions here: [url=http://wiki.centos.org/AdditionalResources/Repositories/CentOSPlus/CentOSWebStack?highlight=%28webstack%29]webstack upgrade[/url]

but I got this error:
[code]==========================================================
--> Finished Dependency Resolution
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package
mod_perl
Error: Missing Dependency: libcairo.so.1 is needed by package libgdiplus
Error: Missing Dependency: libpixman.so.1 is needed by package libgdiplus
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package
perl-DBD-MySQL
==========================================================[/code]

I also ran: yum --enablerepo=centosplus update

but got the same error at the end:
[code]--> Running transaction check
--> Processing Dependency: libcairo.so.1 for package: libgdiplus
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: mod_perl
--> Processing Dependency: libpixman.so.1 for package: libgdiplus
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DBD-MySQL
--> Finished Dependency Resolution
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package mod_perl
Error: Missing Dependency: libcairo.so.1 is needed by package libgdiplus
Error: Missing Dependency: libpixman.so.1 is needed by package libgdiplus
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DBD-MySQL[/code]

What is the recommended way to progress with this?

Post Reply

Return to “CentOS 4 - Server Support”