Apache and mounted volume

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
edmarmota
Posts: 4
Joined: 2009/06/01 20:35:47
Contact:

Apache and mounted volume

Post by edmarmota » 2009/06/01 20:46:02

I've been using apache 2.0.52 for at least a year now, and recently we make an upgrade to our server, with a new SATA HDD.
Our website has a directory outside the main wwwroot that we want to make "larger", so I backup its contents, delete all the stuff and mount a 49GB partition from the SATA HDD (via LVM) in that folder. Then I copied the contents from the backup, change SELinux permissions and strangely the contents are not visible by apache (403 error in browser and (13) error in errolog).
If I unmount the volume and copy the contents back, then thereis no problem.
I've been using an Alias for the folder in httpd.conf.
All the permissions for the folder in the mounted volume are 755. I have chconed all the files I want to access with httpd_sys_content_t tag.
I've been missing something?

If the contents are in the same mounted volume that the wwwroot folder then apache doesn't complain, but if I change the folder to a different volume then the error appear.

Thanks in advance.

FractalizeR
Posts: 102
Joined: 2008/08/23 12:34:08
Contact:

Re: Apache and mounted volume

Post by FractalizeR » 2009/06/06 11:09:20

Who is the owner of files on the partition you mounted?

edmarmota
Posts: 4
Joined: 2009/06/01 20:35:47
Contact:

Re: Apache and mounted volume

Post by edmarmota » 2009/08/03 15:56:24

I've changed the owner of the files of the backup to a user compatible with apache user.

Post Reply

Return to “CentOS 4 - Server Support”