Public key for postfix-2.1.5-2.4.FC3.src.rpm is not installed

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
thabang
Posts: 19
Joined: 2009/05/12 10:32:59

Public key for postfix-2.1.5-2.4.FC3.src.rpm is not installed

Post by thabang » 2009/09/07 08:50:08

Hi All

I'm trying to install mailserver applications!I have installed all the packages i needed and most of them i used Yum to install and coming to postfix since Postfix .rpm binaries do not come with mysql support enabled.I had to Download the Postfix SRPM and build the packages.

I used postfix-2.1.5-2.4.FC3.src.rpm and downloaded it from http://fedora.hostway.co.kr/updates/3/SRPMS/postfix-2.1.5-2.4.FC3.src.rpm and i tried installing it i got the error:

[root@localhost ~]# rpm -ivh postfix-2.1.5-2.4.FC3.src.rpm.1
warning: postfix-2.1.5-2.4.FC3.src.rpm.1: V3 DSA signature: NOKEY, key ID 4f2a6f d2
1:postfix ########################################### [100%]


Can someone help me please i'm struggling,how can i get the public key because i looked at the site and can't get the txt file with that or a file to import.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Public key for postfix-2.1.5-2.4.FC3.src.rpm is not installe

Post by pschaff » 2009/09/09 16:53:23

That was just a warning; however, that's a very old version, and you need to [url=http://wiki.centos.org/HowTos/RebuildSRPM]rebuild[/url] binary RPMs from the SRPM. I'd find at least Fedora Core 6 versions.

Please do the required reading and read this [url=http://wiki.centos.org/FAQ/General#head-472ce8446ebcfc82ca1800f775ba0e629ac835c7]FAQ[/url] before proceeding.

I see you have some later posts about postfix. A forum search for "postfix mysql" and a google on[code]postfix mysql site:centos.org[/code]may provide some useful info.

Post Reply

Return to “CentOS 4 - Server Support”