installing php-pear-db conflicts with php-pear

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
thabang
Posts: 19
Joined: 2009/05/12 10:32:59

installing php-pear-db conflicts with php-pear

Post by thabang » 2009/10/08 14:23:42

Hi all

I'm getting this conflict error and it is giving me hardtime to solve it.
I wanted to install php-pear-db using yum and i got this error:

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
php-pear-db noarch 1.7.13-2.el4.rf rpmforge 133 k

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 133 k
Is this ok [y/N]:

Then i got this:

file /usr/share/pear/test/DB/tests/include.inc from install of php-pear-db-1.7.13-2.el4.rf conflicts with file from package php-pear-4.3.9-3.26
file /usr/share/pear/test/DB/tests/limit.inc from install of php-pear-db-1.7.13-2.el4.rf conflicts with file from package php-pear-4.3.9-3.26
file /usr/share/pear/test/DB/tests/numcols.inc from install of php-pear-db-1.7.13-2.el4.rf conflicts with file from package php-pear-4.3.9-3.26
file /usr/share/pear/test/DB/tests/numrows.inc from install of php-pear-db-1.7.13-2.el4.rf conflicts with file from package php-pear-4.3.9-3.26

Then i performed the command as follow and got the ff output:

[root@server1 sbin]# yum list php-pear\*
Setting up repositories
Reading repository metadata in from local files
Installed Packages
php-pear.x86_64 4.3.9-3.26 installed
Available Packages
php-pear-db.noarch 1.7.13-2.el4.rf rpmforge
php-pear-excel.noarch 0.9.0-1.el4.rf rpmforge
php-pear-log.noarch 1.9.3-1.2.el4.rf rpmforge
php-pear-mail_mime.noarch 1.3.1-1.2.el4.rf rpmforge
php-pear-ole.noarch 0.5-2.2.el4.rf rpmforge
php-pear-phpunit.noarch 1.3.1-1.2.el4.rf rpmforge

Can somebody help me.

Thanks in advance

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

installing php-pear-db conflicts with php-pear

Post by pschaff » 2009/10/09 14:10:51

You have installed packages from a 3rd party repo (RPMforge) without having [url=http://wiki.centos.org/PackageManagement/Yum/Priorities]yum priorities[/url] installed and configured. Apparently there is a failure in the RPMforge package to obsolete the core package it conflicts with. I suggest you report it on the [url=http://lists.rpmforge.net/mailman/listinfo/users]RPMforge list[/url]. As a work-around you could try deleting the core package and see what that breaks, if you really do want to replace core packages with RPMforge packages.

Post Reply

Return to “CentOS 4 - Server Support”