squirrelmail blankpage

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
thabang
Posts: 19
Joined: 2009/05/12 10:32:59

squirrelmail blankpage

Post by thabang » 2009/10/13 07:14:35

I'm using centos 4.7 86_64 and i installed squirrelmail using yum and it displayed a login page and i had to do this step according to the tutorial i used to configure the squirrelmail

versions used

centos 4.7 86_64
squirrelmail-1.4.8-5.el4.centos.8
php-cli-5.1.6-3.el4s1.10
php-ldap-5.1.6-3.el4s1.10
php-pdo-5.1.6-3.el4s1.10
php-common-5.1.6-3.el4s1.10
php-5.1.6-3.el4s1.10
php-mysql-5.1.6-3.el4s1.10
phpmyadmin-2.11.9.5-1.el4.rf
php-pear-DB-1.7.6-6.el4.centos
php-mbstring-5.1.6-3.el4s1.10
php-pear-1.4.11-1.el4s1.1
change_sqlpass-3.3-1.2.tar.gz
compatibility-2.0.13-1.0.tar.gz

http://www.howtoforge.net/virtual-users-domains-postfix-courier-mysql-squirrelmail-centos-5.3-x86_64-p5

I got the blank page after configuring as it shows on the link.

What must i do??

someone tell me what to do.......Please

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

squirrelmail blankpage

Post by pschaff » 2009/10/13 17:44:13

Those are not CentOS 4 php packages. Are they from the c4-testing repo, or elsewhere? The tutorial you cite is for CentOS 5.3 and is for virtual users and domains. Do really need those?

You should also update the base distro to 4.8.

thabang
Posts: 19
Joined: 2009/05/12 10:32:59

Re: squirrelmail blankpage

Post by thabang » 2009/10/14 14:27:48

How do i update from centos 4.7 to 4.8,do i have to find a 4.8 server CD?
Coz i tried again using this php packages but still
php-pear-4.3.9-3.26
php-4.3.9-3.26
php-mysql-4.3.9-3.26
phpmyadmin-2.11.9.5-1.el4.rf
php-ldap-4.3.9-3.26
php-mbstring-4.3.9-3.26
php-pear-db-1.7.13-2.el4.rf

I used the tutorial for http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-centos-4.8-i386
But I can't display anything on squirrelmail login page

thabang
Posts: 19
Joined: 2009/05/12 10:32:59

Re: squirrelmail blankpage

Post by thabang » 2009/10/14 14:44:29

How do i update to distro 8?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: squirrelmail blankpage

Post by pschaff » 2009/10/14 15:02:40

yum update

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: squirrelmail blankpage

Post by pschaff » 2009/10/14 15:13:12

[quote]
thabang wrote:
...
I used the tutorial for http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-centos-4.8-i386
But I can't display anything on squirrelmail login page[/quote]

It is impossible to say what you may have done installing/removing different versions of packages, following 5.3 directions on 4.X, not to mention whatever was involved in the tarballs you mentioned earlier. Check the Apache logs for errors.

You did not describe what you are really trying to accomplish, nor answer the question about whether you need the complexity of virtual domains and users.

thabang
Posts: 19
Joined: 2009/05/12 10:32:59

Re: squirrelmail blankpage

Post by thabang » 2009/10/15 06:28:07

Okay,I want to configure a mailserver that will use virtual domain and users for internal use only and I got The centos 4.7 server CD x86_64,Can you please direct me to the right path and my small network is connecting to the ISP and later on I can upgrade it to send externally,Since right now i don't have a registered domain for this task.


Please help

My email is [removed by moderator]

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: squirrelmail blankpage

Post by pschaff » 2009/10/15 12:04:13

I fail to understand what good a virtual domain and users will be for internal use, but that may just be my ignorance.

Have you checked the Apache logs (/var/log/httpd/*) for errors? Opened the firewall or at lease required ports to the local subnet?

Post Reply

Return to “CentOS 4 - Server Support”