cannot mount nfs4

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
matt_garman
Posts: 40
Joined: 2006/10/18 14:14:21

cannot mount nfs4

Post by matt_garman » 2009/10/13 13:29:55

I am trying to deploy Kerberos-authenticated NFSv4 on CentOS 4.x.

For the most part, I followed [url=http://www.itp.uzh.ch/~dpotter/howto/kerberos]this document[/url], except that I ignored the LDAP stuff (don't need that, just krb5+nfs4).

Here's what happens when I try to mount:

[code]
# mount -v -t nfs4 -o sec=krb5 192.168.187.75:/share mnt
mount: pinging: prog 100003 vers 4 prot tcp port 2049
mount: block device 192.168.187.75:/share is write-protected, mounting read-only
mount: pinging: prog 100003 vers 4 prot tcp port 2049
mount: cannot mount block device 192.168.187.75:/share read-only
[/code]

There is no firewall running on any of the machines.

Here is the /etc/exports file on 192.168.187.75:

[code]
/export gss/krb5(sync,rw,fsid=0,insecure,no_subtree_check,anonuid=65534,anongid=65534)
/export/share gss/krb5(sync,rw,nohide,insecure,no_subtree_check,anonuid=65534,anongid=65534)
[/code]

Here is what rpcinfo shows...

[code]
# rpcinfo -p 192.168.187.75
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 697 status
100024 1 tcp 700 status
100011 1 udp 864 rquotad
100011 2 udp 864 rquotad
100011 1 tcp 867 rquotad
100011 2 tcp 867 rquotad
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 4 udp 2049 nfs
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100021 1 udp 32778 nlockmgr
100021 3 udp 32778 nlockmgr
100021 4 udp 32778 nlockmgr
100021 1 tcp 35837 nlockmgr
100021 3 tcp 35837 nlockmgr
100021 4 tcp 35837 nlockmgr
100005 1 udp 880 mountd
100005 1 tcp 883 mountd
100005 2 udp 880 mountd
100005 2 tcp 883 mountd
100005 3 udp 880 mountd
100005 3 tcp 883 mountd
[/code]

If anyone can offer any thoughts or suggestions as to what might be wrong, I'd be most grateful. Also, if I need to post any more information, please don't hesitate to ask.

Thanks,
Matt

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

cannot mount nfs4

Post by toracat » 2009/10/13 14:39:12

The document you referenced has a note in the nfs4 section that says:

"NFSv4 using Kerberos authentication in RHEL4 seems to be broken with the latest patch level. When I find a solution it will be posted here."

Maybe that's why it's not working (broken) ??

matt_garman
Posts: 40
Joined: 2006/10/18 14:14:21

Re: cannot mount nfs4

Post by matt_garman » 2009/10/13 15:56:05

[quote]
toracat wrote:
The document you referenced has a note in the nfs4 section that says:

"NFSv4 using Kerberos authentication in RHEL4 seems to be broken with the latest patch level. When I find a solution it will be posted here."

Maybe that's why it's not working (broken) ??[/quote]

Indeed, I saw that, but forged ahead anyway. :) The last update for that document is August of 2008, so I was hoping that whatever the issue is has since been fixed, and the author forgot to update that page.

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: cannot mount nfs4

Post by toracat » 2009/10/13 16:25:05

This upstream bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=237108

may or may not be related to your case. In any case, it's been unattended for over 2 years... :-x

Post Reply

Return to “CentOS 4 - Server Support”