Mailscanner and Perl-IO problems

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
supremedalek
Posts: 26
Joined: 2008/02/23 16:35:19

Mailscanner and Perl-IO problems

Post by supremedalek » 2010/01/26 20:38:02

Machine in question is a centos 4.8 box which runs postfix, dovecot, and mailscanner. For whatever reason, mailscanner is giving the

[code]MailScanner status

**** ERROR: You must upgrade your perl IO module to at least
**** ERROR: version 1.2301 or MailScanner will not work![/code]

message when it is run. As a result, there is a ton of email waiting on the queue. What can I do about this error? I checked which version of perl-IO I have and it seems to be the right one:

[code]yum info perl-IO
Loading "priorities" plugin
Setting up repositories
Reading repository metadata in from local files
408 packages excluded due to repository priority protections
Installed Packages
Name : perl-IO
Arch : i386
Version: 1.2301
Release: 1.el4.rf
Size : 183 k
Repo : installed
Summary: Perl module to load various IO modules

Description:
perl-IO is a Perl module to load various IO modules.[/code]

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Mailscanner and Perl-IO problems

Post by pschaff » 2010/01/26 21:00:39

A google on [code]
centos-4 ERROR: You must upgrade your perl IO module to at least version 1.2301 or MailScanner will not work[/code]
finds:
http://forum.configserver.com/showthread.php?t=2722

HTH

Post Reply

Return to “CentOS 4 - Server Support”