can't send mails, from vsites or command line

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
fsoyer
Posts: 2
Joined: 2010/05/06 17:27:35

can't send mails, from vsites or command line

Post by fsoyer » 2010/05/06 18:37:15

Hi all,
I have a problem with a 4.8 server. It's exactly a BlueQuartz one, but I don't believe that this panel has a responsibility in this.
In fact, I have two other BlueQuartz servers and a BlueOnyx one, and on all this servers the mails can be sended from command line or from sites.
And, YES ;) , I have compared the setup of the bad server with the others, and it's why I post here : the setup IS (seems ?...) to be perfectly identical !

The problem :
From command line, I try :
[quote]# mail -v root@myserver.domain.fr
Subject: test
test
.
Cc:
root@myserver.domain.fr... Connecting to [127.0.0.1] via relay...
220 localhost ESMTP Sendmail Ready; Thu, 6 May 2010 20:07:36 +0200
>>> EHLO myserver.domain.fr
250-myserver.domain.fr Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5 LOGIN PLAIN
250-STARTTLS
250-DELIVERBY
250 HELP
>>> STARTTLS
220 2.0.0 Ready to start TLS
>>> EHLO myserver.domain.fr
250-myserver.domain.fr Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5 LOGIN PLAIN
250-DELIVERBY
250 HELP
>>> MAIL From: SIZE=51 AUTH=root@myserver.domain.fr
550 5.1.1 ... User unknown
root... Using cached ESMTP connection to [127.0.0.1] via relay...
>>> RSET
250 2.0.0 Reset state
>>> MAIL From: SIZE=1075
250 2.1.0 ... Sender ok
>>> RCPT To:
>>> DATA
550 5.1.1 ... User unknown
503 5.0.0 Need RCPT (recipient)
>>> RSET
250 2.0.0 Reset state
>>> RSET
250 2.0.0 Reset state
postmaster... Using cached ESMTP connection to [127.0.0.1] via relay...
>>> MAIL From: SIZE=2099
250 2.1.0 ... Sender ok
>>> RCPT To:
>>> DATA
550 5.1.1 ... User unknown
503 5.0.0 Need RCPT (recipient)
>>> RSET
250 2.0.0 Reset state
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 myserver.domain.fr closing connection
[/quote]
As you can see, NO LOCAL USERS ARE KNEW !

I test it with telnet :
[quote]# telnet myserver.domain.fr 25
Trying 192.168.1.26...
Connected to myserver-eth0.domain.fr (192.168.1.26).
Escape character is '^]'.
220 myserver.domain.fr ESMTP Sendmail Ready; Thu, 6 May 2010 20:25:27 +0200
EHLO myserver.domain.fr
250-myserver.domain.fr Hello myserver.domain.fr [192.168.1.26], pleased to meet you
250 ENHANCEDSTATUSCODES
MAIL FROM: root
550 5.1.1 User unknown
MAIL FROM: root@myserver.domain.fr
550 5.1.1 User unknown
MAIL FROM: root@localhost.localdomain
550 5.1.1 User unknown
MAIL FROM: root@localdomain
550 5.1.1 User unknown
[/quote]
:-?
I really don't understand.
Some infos :
[b]/etc/hosts[/b]
[quote]# /etc/hosts
# Auto-generated file. Keep your customizations at the bottom of this file.
127.0.0.1 localhost localhost.localdomain
192.168.1.26 myserver.domain.fr myserver-eth0.domain.fr myserver-eth0
#END of auto-generated code. Customize beneath this line.
### Begin - Nuonce hosts Fix
### End - Nuonce hosts Fix
[/quote]
[b]hostname[/b]
[quote]# hostname
myserver.domain.fr
[/quote]
[b]/etc/mail/local-host-names[/b]
[quote]# local-host-names - include all aliases for your machine here.
# Cobalt System Section Begin
myserver.domain.fr
# Cobalt System Section End
# BEGIN VSite Hosts (don't edit between BEGIN and END)
... (some vsites)
[/quote]
The others files are too big, I post some parts if you want.

Pleeease, give me an idea !

fsoyer
Posts: 2
Joined: 2010/05/06 17:27:35

Re: can't send mails, from vsites or command line

Post by fsoyer » 2010/05/07 07:37:43

Some additional logs, when trying to send mail from root to root :
[quote]May 7 09:20:34 vs1 sendmail[21745]: o477KYOL021745: from=root, size=51, class=0, nrcpts=1, msgid=, relay=root@localhost
May 7 09:20:34 vs1 sendmail[21745]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
May 7 09:20:34 vs1 sendmail[21745]: o477KYOL021745: to=root@myserver.domain.fr, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30051, relay=[127.0.0.1] [127.0.0.1], dsn=5.0.0, stat=Service unavailable
May 7 09:20:34 vs1 sendmail[21745]: o477KYOL021745: o477KYOM021745: DSN: Service unavailable
May 7 09:20:34 vs1 sendmail[21745]: o477KYOM021745: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31075, relay=[127.0.0.1], dsn=5.1.1, stat=User unknown
May 7 09:20:34 vs1 sendmail[21745]: o477KYOM021745: o477KYON021745: return to sender: User unknown
May 7 09:20:34 vs1 sendmail[21745]: o477KYON021745: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32099, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
May 7 09:20:34 vs1 sendmail[21745]: o477KYOM021745: Losing ./qfo477KYOM021745: savemail panic
May 7 09:20:34 vs1 sendmail[21745]: o477KYOM021745: SYSERR(root): savemail: cannot save rejected email anywhere
[/quote]

Post Reply

Return to “CentOS 4 - Server Support”