xfce4 would not start

Support for security such as Firewalls and securing linux
Post Reply
slimeph
Posts: 12
Joined: 2006/08/04 05:45:39

xfce4 would not start

Post by slimeph » 2006/11/17 02:53:53

I have installed xfce4 using the command

[quote]yum groupinstall XFCE-4.2 [/quote]

as describe by Sir foxb. The problem now is that I am encountering this following message

[quote]/usr/bin/startxfce4: line 45: exec: xinit: not found[/quote]

but it is there examining line 45 of /usr/bin/startxfce4 there is a line with the following:

[quote]exec $prog /etc/xdg/xfce4/xinitrc $*[/quote]

May I ask what could be the problem here?

Thanks in advance.

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

xfce4 would not start

Post by foxb » 2006/11/17 14:36:25

Could you post the result of

[code]
yum grouplist
[/code]

slimeph
Posts: 12
Joined: 2006/08/04 05:45:39

Re: xfce4 would not start

Post by slimeph » 2006/11/19 05:14:01

Sir,

It came again back to cannot find valid repositories again.. like the one I have posted about the other time.. Tried also this one:

[url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=3456&forum=27&post_id=9752#forumpost9752]post about centos-base-repo problem[/url]

but got the problem on the attached picture.

The last time I have check my CentOS-Base.repo file I have cross-checked it with you and its the same.. and I have updated it following the steps in howtoforge.com.. the perfect setup for server article.

What could be wrong with this Sir?

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: xfce4 would not start

Post by foxb » 2006/11/20 15:11:27

First try
yum clean all --> then
yum update

also

rpm -q yum

mine is: yum-2.4.3-1.c4

yum.conf
[code]
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=centos-release
tolerant=1
exactarch=1
retries=20
obsoletes=1
gpgcheck=1
[/code]

Base.repo
[code]
[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4

#released updates
[update]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
..... <---- rest is similar
[/code]

What is your network layout?

slimeph
Posts: 12
Joined: 2006/08/04 05:45:39

Re: xfce4 would not start

Post by slimeph » 2006/11/24 01:15:57

Accessing the net through a gateway but that is not a proxy server.. No authentication required.. I will use your command first and post the results here..

slimeph
Posts: 12
Joined: 2006/08/04 05:45:39

Re: xfce4 would not start

Post by slimeph » 2006/12/05 06:15:47

Another thing sir, if i am using it as a virtual machine would it cause some problems in updates?

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: xfce4 would not start

Post by foxb » 2006/12/05 14:18:20

[quote]
slimeph wrote:
Another thing sir, if i am using it as a virtual machine would it cause some problems in updates?[/quote]
Which one?

Usually no, but consult your VM documentation.

slimeph
Posts: 12
Joined: 2006/08/04 05:45:39

Re: xfce4 would not start

Post by slimeph » 2006/12/06 00:42:58

As I was about to post this...

[quote]Actually the first time I have encountered this is I have installed it and dual-booted it with an xp machine.. That was my [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=4796&forum=32&post_id=14054]first post[/url].. This time I have installed it using a virtual machine.. Created a hard disk image using qemu and installed it there using the iso I have downloaded.. This time I have trouble updating.. I am using vmware player...[/quote]

I am updating my centos installation.. Apparently the problem in the update is my own network.. A lot of youtube and bandwidth eater users.. I then updated it early in the morning and voila.. It came on easy.. Thanks Sir foxb.

Post Reply

Return to “CentOS 4 - Security Support”