error with caracter set

Support for webhosts that use CentOS
Post Reply
elsteph
Posts: 7
Joined: 2006/08/02 13:30:23
Contact:

error with caracter set

Post by elsteph » 2006/11/02 08:20:14

after a good install (most setup by default), when i use some frenche caracter like:

" à, é è ç ù ,...", i have this result
with IE6:
[img align=left]http://jstechnics.homelinux.net/images/Clipboard01.jpg[/img]

and firefox 2.0:
[img align=left]http://jstechnics.homelinux.net/images/Clipboard02.jpg[/img]

any idea where is my fault ? into apache, i supose (httpd.conf ?)

[url=http://jstechnics.homelinux.net/awstat.html]the link to test[/url]

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

error with caracter set

Post by foxb » 2006/11/02 15:24:40

You need to change default site encoding from UTF-8 to ISO-8859-1 all info at your site is encoded with it.

elsteph
Posts: 7
Joined: 2006/08/02 13:30:23
Contact:

Re: error with caracter set

Post by elsteph » 2006/11/02 16:14:27

all my pages are into ISO...

[code]
<html>

<head>
<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<title>ElSteph @ Home</title>
</head>

[/code]
idem for this one (auto generated by awstats)
[code]<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang='fr'>
<head>
<meta name="generator" content="AWStats 6.6 (build 1.882) from config file awstats.elsteph.conf (http://awstats.sourceforge.net)">
<meta name="robots" content="noindex,nofollow">
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
<meta http-equiv="description" content="Awstats - Advanced Web Statistics for http://jstechnics.homelinux.net (2006-11)">
<title>Statistiques de http://jstechnics.homelinux.net (2006-11)</title>
<style type="text/css">[/code]

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: error with caracter set

Post by foxb » 2006/11/02 19:03:00

In http.conf comment this line
[code]
#AddDefaultCharset UTF-8
[/code]

Until this all pages are UTF-8

elsteph
Posts: 7
Joined: 2006/08/02 13:30:23
Contact:

Re: error with caracter set

Post by elsteph » 2006/11/04 06:08:11

[quote]
foxb wrote:
In http.conf comment this line
[code]
#AddDefaultCharset UTF-8
[/code]

Until this all pages are UTF-8[/quote]
IT WORK :-) :-)
thanks for all

don't forget to specifiy into balise of all your pages => lang='fr' like this:
[code]<html lang='fr'>
[/code]

Post Reply

Return to “CentOS 4 - Webhosting Support”