Kernel Panic Error - help!!!

Support for webhosts that use CentOS
Post Reply
bsasninja
Posts: 3
Joined: 2007/02/01 23:08:07

Kernel Panic Error - help!!!

Post by bsasninja » 2007/02/01 23:18:40

Two weeks ago I started to have kernel panic errors. Im using CentOs 4.4 with kernel 2.6.9-42.0.3.ELsmp on a dual opteron cpu with 4gb of ram.
The kernel panic error I´m having is the same posted at http://bugs.centos.org/view.php?id=1601

I did a search on google and I found that people using 2.6.9-42.0.2.ELsmp and 2.6.9-42.0.3.ELsmp are having the same issue.
Today i saw that there is a new kernel available: 2.6.9-42.0.8.ELsmp but the changelog hasnt anything related to the quota bug.

So how do I fix this? Do I have to go a version below 2.6.9-42.0.2.ELsmp? Anyone had this problem?

I wait comments.

Thanks

jimmy20013
Posts: 21
Joined: 2007/03/30 07:15:06

Re: Kernel Panic Error - help!!!

Post by jimmy20013 » 2007/03/31 03:24:56

[quote]
I show it being fixed in this kernel:
* Mon Oct 30 2006 Jason Baron [2.6.9-42.22]
-Fix BUG() check in invalidate_dquots() (David Milburn) [209639]

We have 3 kernels > 2.6.9-42.22 currently in our testing repo that contain that fix.

NOTE: Testing kernels are TESTING ... they potentially eat babies, etc. They are not officially released or recommended on production boxes.

Testing repo:
http://dev.centos.org/centos/4/ [^]

http://wiki.centos.org/Repositories [^]

Upstream test kernels:
http://people.redhat.com/~jbaron/rhel4/ [^
Thanks[/quote]


You can either use the beta kernels that are in Testing or if yours is a production box then I suggest that you wait for the stable versions of the kernels to be released.

Post Reply