Apache won´t start

Support for webhosts that use CentOS
User avatar
toracat
Forum Moderator
Posts: 7230
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Apache won´t start

Postby toracat » 2007/11/13 15:49:39

n3r0x wrote:
# ls -l /usr/lib64/libldap-2.*
lrwxrwxrwx 1 root root 20 Nov 10 01:31 /usr/lib64/libldap-2.2.so.7 -> libldap-2.2.so.7.0.6
-rwxrwxrwx 1 apache apache 224296 May 3 2007 /usr/lib64/libldap-2.2.so.7.0.6

Mine looks like this:

# ls -l /usr/lib64/libldap-2.*
lrwxrwxrwx 1 root root 20 Jul 28 13:38 /usr/lib64/libldap-2.2.so.7 -> libldap-2.2.so.7.0.6
-rwxr-xr-x 1 root root 224296 May 2 2007 /usr/lib64/libldap-2.2.so.7.0.6

I have the same version of httpd and openldap as yours. Something on your system has changed the owner and group of the libldap-2.2.so.7.0.6 file (I suspect other files as well). At this point, you might want to go ahead and re-install openldap and see if that fix the problem. However, it is possible that whatever caused this change broke things other than openldap.

If you decide to replace the openldap rpm (after saving any customized file like ldap.conf),

wget http://mirror.centos.org/centos/4/os/x8 ... x86_64.rpm

rpm -Uvh --replacepkgs openldap-2.2.13-7.4E.x86_64.rpm

After that, re-run 'rpm -V openldap' to make sure it does not show any line for libldap-2.2.so.7.0.6

hi_vkkadam
Posts: 74
Joined: 2007/11/05 16:08:34
Location: Pune

Re: Apache won´t start

Postby hi_vkkadam » 2007/11/23 17:57:43

reinstall the openladp also ldap plugins for apache,
also change the ownership as chown apache.apache /var/www/html