Problem with Apache

Support for webhosts that use CentOS
Paulinho
Posts: 3
Joined: 2007/11/16 10:03:04

Problem with Apache

Postby Paulinho » 2007/11/16 10:12:54

Hi,

I have CactiEZ with CentOS 4.5. I used a virtualization VMWare of Linux in Windows Server 2003. Recently I installed OCS Inventory NG that needs the mod_perl 2 installed. I forget to install it after and now I have a Apache problem.
I have the message error: "httpd: syntax error on line 16 of /etc/httpd/conf.d/ocsinventory.conf: Invalid command 'PerlSetEnv', perhaps mis-spelled or defined by a module not included in the server configuration'.
So my Apache 2 don't start. And I want to install mod_perl and I can't do that. It can find apache (it's turned off).

Someone can help me?

Thanks.

Paulinho
Posts: 3
Joined: 2007/11/16 10:03:04

Re: Problem with Apache

Postby Paulinho » 2007/11/16 11:47:48

It says to me: 'to provide a full path to 'apxs' executable (press Enter if you don't have it installed)'. Then when I press Enter it says: 'Please provide the location of the Apache directory:'.

Paulinho
Posts: 3
Joined: 2007/11/16 10:03:04

Re: Problem with Apache

Postby Paulinho » 2007/11/16 15:23:31

Hi,

Apache is working now.

I have this message but I think that is not important:

Code: Select all

 
Starting httpd: httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName [ OK ]


I still have the same difficulty for installing mod_perl. The problem, I think, is the symlink or the 'apxs' that I can't find in my directory. I made httpd -l and the mod_so.c which is necessary for the apxs to install mod_perl.