Page 1 of 1

FireFox i386 on X86_64 dependancy problems

Posted: 2006/06/07 22:45:28
by jimtheguern
Hi everyone

Just installed CentOS 4.3 on an AMD64 machine. Everything went really well, just having a problem with firefox. I need to be able to use both java and flash with the browser so I want to change to the i386 version. Managed to find the rpms ok but when I try to install it it comes up with the following failed dependancies:

libbonoboui-2.so.0 is needed by firefox-1.5.0.1-2.c4.centos.i386
libgnomeui-2.so.0 is needed by firefox-1.5.0.1-2.c4.centos.i386

Both of these are in the lib64 directory and I have created links ot them in the lib directory. I am still getting the failed dependancies.

Firefox 1.0.7 works fine I would just like to be able to use the newer version.

Can anyone help?

Re: FireFox i386 on X86_64 dependancy problems

Posted: 2006/06/07 23:04:05
by WhatsHisName
Try downloading libbonoboui.i386 & libgnomeui.i386 and install them with rpm.

[code]# rpm -Uvh [package-file] --force[/code]

FireFox i386 on X86_64 dependancy problems

Posted: 2006/06/08 03:35:21
by Lenard
Try downloading both the i386 and x86_64 versions and installing them;

rpm -Uvh libbonoboui*.rpm libgnomeui*.rpm --force

The force switch is needed because you already have one version (i386 or x86_64) installed.

Example of both versions installed (notice the command structure);

$ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" libbonoboui libgnomeui | sort
libbonoboui-2.8.1-4.i386.rpm
libbonoboui-2.8.1-4.x86_64.rpm
libgnomeui-2.10.0-1.i386.rpm
libgnomeui-2.10.0-1.x86_64.rpm

Re: FireFox i386 on X86_64 dependancy problems

Posted: 2006/06/08 14:26:17
by jimtheguern
Thanks

That worked like a charm. Everything is working great now.

Thanks again :-D