Multilib Perl

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
eharmic
Posts: 4
Joined: 2006/06/24 03:13:14
Contact:

Multilib Perl

Post by eharmic » 2006/06/24 03:29:39

Hi,

I am setting up Centos 4.3 on an AMD x86_64 based machine.

Unfortunately, I have some software that relies on a few perl modules that use binary extensions, for which I don't have the source code, nor an x86_64 version. I only have an i386 version. Ideally I would like to run 64bit perl for most applications, but be able to use 32bit for the one application that has this issue.

'yum list' tells me there is no .i386 version of perl in the repository.

Is it as simple as adding the .i386 repository for Centos 4.3, then installing the perl.i386 & any associated dependancies? Or will that conflict with various files in the 64bit packages?

Or can I somehow install the .i386 version with a different prefix, to avoid file conflicts, then use a different path to run the i386 version? If I do that, will yum update work on it, remembering t

Or maybe I need to rebuild perl to be multilib compatible in some way?

Regards //
Mike Harris

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”