PHP-GD problems

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
rajenkins
Posts: 10
Joined: 2006/06/26 15:09:13

PHP-GD problems

Post by rajenkins » 2006/06/26 16:07:57

Hi,

has anyone got GD working correctly on Centos 4.3 x86_64?

I have tried several version of PHP & presently I'm using the RPMs built by sankaman2k.
(after upgrading mysql to V5.)

PHP itself works fine & phpinfo shows GD as being enabled, but as soon as I try to use any GD function the script dies at that point.
This happens even with just ' $gx=gdinfo();' not only image manipulation functions.

I have restarted apache after every config change & restarted the machine a couple of time to make sure everything is correctly installed.

I believe I have all the libraries it may need in place, I tried building PHP5 from source & crosschecked the configure script ouput to ensure it was finding libjpg, libpng etc.


I've now spent two days solid on this...
Any ideas greatly appreciated!

Robert Jenkins.

rajenkins
Posts: 10
Joined: 2006/06/26 15:09:13

Re: PHP-GD problems

Post by rajenkins » 2006/06/29 22:10:36

I ended up completely removing php again, then downloaded the gd-* rpms from centos.org, installed them over the existing ones with rpm -U --force gd* and then reinstalled sankaman2k's set of PHP5.1 RPMs.

Restarted apache and gd_info() worked!
(Note the gdinfo() in the above post was a typo, I had it correctly in the php file).

I don't have a clue why this has changed anything, as according to phpinfo it's using it's own version of gd?

Anyway, it is now working & processing jpgs fine..
(I had to increase the memory limit in php.ini before it would handle hi-res images).

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”