FireFox java pluggin AMD64

Support for the other architectures (X86_64, s390(x) and PowerPC)
couren
Posts: 1
Joined: 2006/08/17 15:08:24

FireFox java pluggin AMD64

Post by couren » 2006/08/17 15:32:21

Hello,
I've just installed CentOS4.3 ofor AMD 64 .
I did not succeed in installing jre_1.5.06 in order to use it as firefox plugin. ..
I did a rpm -iv jre_.1.5.06_06.rpm but then... What to do.
FireFox still can't find the pluggin

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: FireFox java pluggin AMD64

Post by Lenard » 2006/08/17 21:06:30

OK one more time (not to you, but I have answered this at least a fews times already)..............

No 64-bit jre plugin is availabe

No 64-bit flash player plugin is avaialble

No Adobereader 64-bit plugin is available

In fact most plugins are nor 64-bit compliant or in other words they do not work. And no you cannot install the 32-bit plugin and expect it to work in a 64-bit version of firefox or mozilla or seamonkey.

Solution: Remove the 64-bit version and install the 32-bit version makeing sure you also install the 32-bit libs as required.

ehurst
Posts: 13
Joined: 2005/11/19 03:27:36
Location: Oklahoma City
Contact:

Re: FireFox java pluggin AMD64

Post by ehurst » 2006/08/30 22:43:21

Duly noted. However, I am ignorant of the method for getting the proper collection of dependenices for 32-bit FF and friends. Has anyone made list, or is there some manipulation possible with yum?

Disregard; I solved it manually:

libgnome-2.8.0-2.i386.rpm
libglade2-2.4.0-5.i386.rpm
libgnomecanvas-2.8.0-1.i386.rpm
libbonoboui-2.8.0.99cvs20040929-2.i386.rpm
gnome-keyring-0.4.0-1.i386.rpm
libgnomeui-2.8.0-1.i386.rpm
firefox-1.5.0.5-0.el4.1.centos4.i386.rpm

dndo
Posts: 3
Joined: 2006/04/25 17:58:38
Location: Minneapolis, Minnesota, USA

Re: FireFox java pluggin AMD64

Post by dndo » 2007/01/08 21:44:31

How did you solve this problem?

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: FireFox java pluggin AMD64

Post by Lenard » 2007/01/08 22:38:36

The easy way is to;

rpm -e firefox

yum install firefox-1.5.0.9-0.1.el4.centos4.i386

xynapz
Posts: 4
Joined: 2007/03/10 15:53:01

Re: FireFox java pluggin AMD64

Post by xynapz » 2007/03/10 17:22:35

[quote]
Lenard wrote:
The easy way is to;

rpm -e firefox

yum install firefox-1.5.0.9-0.1.el4.centos4.i386[/quote]

'yum install firefox-1.5.0.9-0.1.el4.centos4.i386' doesnt work for me i get the message 'No Match for argument: firefox-1.5.0.9-0.1.el4.centos4.i386'

im running centos 4.4 64bit and want the 32bit version of firefox (due to all the incompatible plugins). Im guessing that the 'no argument match' means it cant find the i386 firefox, but when i type 'yum install firefox' it finds the 86_64 version. So do i need to enable or add some i386 repositories in order to install i386 software? advice would be appreciated - thanks.

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: FireFox java pluggin AMD64

Post by Lenard » 2007/03/11 12:51:42

Well for one firefox has been updated since I wrote that reply, and you are close to the right command;

yum install firefox.i386

You may want to manually edit and change your /etc/yum.repos.d/CentOS-Base.repo file and add 32bit support.

Example (maybe add something like this):

[base-32bit]
name=CentOS-$releasever - Base 32bit
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=i386&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/i386/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4

[update-32bit]
name=CentOS-$releasever - Updates 32bit
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=i386&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/i386/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4

User avatar
WhatsHisName
Posts: 1544
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: FireFox java pluggin AMD64

Post by WhatsHisName » 2007/03/11 18:27:50

Lenard: It might be a good idea to disable the i386 repos by default (enable=0).

Much as is the case for enabling 3rd-party repos by default, you might get some unexpected updates.

[code]# [b]uname -rpmi[/b]
2.6.9-42.0.10.ELsmp x86_64 x86_64 x86_64

# [b]yum update yum[/b]
No Packages marked for Update/Obsoletion

# [b]yum list yum[/b]
Installed Packages
yum.noarch 2.4.3-1 installed

# [b]yum --enablerepo=base.i386 --enablerepo=updates.i386 update yum[/b]
Dependencies Resolved
=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
yum noarch 2.4.3-1.c4 base.i386 385 k

Transaction Summary
=============================================================================
Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)
Total download size: 385 k
Is this ok [y/N]: n

# [b]cat /etc/yum.repos.d/CentOS-i386.repo[/b]
# Configured for local i386 mirrors
#
[base.i386]
name=CentOS-$releasever - Base
baseurl=
ftp://192.168.11.203/pub/centos/$releasever/os/i386/
ftp://192.168.11.216/pub/centos/$releasever/os/i386/
gpgcheck=1
[b]enabled=0[/b]
gpgkey=ftp://192.168.11.203/pub/centos/RPM-GPG-KEY-centos4

#released updates
[updates.i386]
...[/code]
Fortunately, that update is probably trivial.

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: FireFox java pluggin AMD64

Post by Lenard » 2007/03/11 19:31:51

For sure, I was not suggesting that the 32-bit side of the repo be enabled by default just long enough to get the 32-bit version of firefox with the dependencies installed.

Both you and I have seen 'all the fun' having a 'bad mix' of third party repos installed and enabled cause. Having rpmforge, atrpms, and freshrpms repos (and a few others) available is a good idea. Having them enabled all the time is not, especially for example atrpms and the CentOS updates at the same time. Having the 32-bit side of the CentOS repo enabled all the time is not good choice also.

User avatar
WhatsHisName
Posts: 1544
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: FireFox java pluggin AMD64

Post by WhatsHisName » 2007/03/11 21:22:03

In addition to having unplanned 3rd-party updates bite me on the rear occasionally, minimizing 3rd-party repo usage also tends to make doing OS version-upgrades using yum easier.

Since you often have to uninstall the 3rd-party packages to do the yum-based version-upgrades in the FC-series, I assume the same will be true for yum upgrading to the upcoming CentOS5 release...

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”