installing ocfs2 to unsupported kernel

Installation and support for Oracle DB on CentOS.
Post Reply
bellc
Posts: 2
Joined: 2006/05/22 22:07:40

installing ocfs2 to unsupported kernel

Post by bellc » 2006/05/22 22:18:41

I am new to the linux environment. I've been tasked with learning to install Oracle 10g RAC, so I converted two of my desktops to CentOS 4, grabbed 4 ethernet cards, 2 firewire cards, bought a drive in the list of supported drives at
http://www.oracle.com/technology/pub/articles/hunter_rac10gr2.html
and started off on my journey. I first learned that the default kernel didn't provide support for the firewire hard drive, so I learned to update to the unsupported kernel. After the 2 linux installs could both see the drive, I started trying to install ocfs2, but something is amiss. I can see the modules in the 2.6.9-34.EL kernel direcories, but not the 2.6.9-34.106.unsupported directories under /lib/modules. I ran the install using the unsupported kernel.

Here is what I see now:

[root@linux1 john]# rpm --rebuilddb
[root@linux1 john]# rpm -ev ocfs2-2.6.9-34.EL-1.2.1-1.i686.rpm ocfs2console-1.2.1-1.i386.rpm ocfs2-tools-1.2.1-1.i386.rpm
error: package ocfs2-2.6.9-34.EL-1.2.1-1.i686.rpm is not installed
error: package ocfs2console-1.2.1-1.i386.rpm is not installed
error: package ocfs2-tools-1.2.1-1.i386.rpm is not installed
[root@linux1 john]# rpm -Uvh --ignoreos ocfs2-2.6.9-34.EL-1.2.1-1.i686.rpm ocfs2console-1.2.1-1.i386.rpm ocfs2-tools-1.2.1-1.i386.rpm
Preparing... ########################################### [100%]
package ocfs2-tools-1.2.1-1 is already installed
package ocfs2-2.6.9-34.EL-1.2.1-1 is already installed
package ocfs2console-1.2.1-1 is already installed


Could someone help me out here?
Thanks,
John

bellc
Posts: 2
Joined: 2006/05/22 22:07:40

Re: installing ocfs2 to unsupported kernel

Post by bellc » 2006/06/01 03:46:41

Well, call me a newbie. The modules were installed to the 2.6.9-34.EL kernel instead of the 2.6.9-34.106.unsupported kernel that I was using. Once I copied the modules to the correct location and ran 'depmod' everything continued normally.

John

igbin
Posts: 1
Joined: 2006/09/07 16:12:52

Re: installing ocfs2 to unsupported kernel

Post by igbin » 2006/09/07 16:24:47

hey i am trying to do the same thing that you doing. I am stuck at the firewire setup. I am using centos 4.4 and would like to know if there is a seperate module that i need to download. The one specified in jeff hunters rac install does not seem to work. Any ideas, I need help. how did you update your kernels

Post Reply

Return to “CentOS 4 - Oracle Installation and Support”