Installing oracle10g on centos 4.3 i86_64

Installation and support for Oracle DB on CentOS.
Post Reply
kheldar
Posts: 11
Joined: 2006/06/19 19:42:26

Installing oracle10g on centos 4.3 i86_64

Post by kheldar » 2006/07/02 13:53:23

Hi,

I've downloaded the latest oracle linux i86_64 database package, and I'm trying to install it on centos 4.3 i86_64 but it's complaining at the make stage that it can't find crt1.o.

I've checked on the machine, and it has crt1.o in /usr/lib64.

It seems oracle is trying to link something for a 32 bit version, and as such, it's complaining.

Should the installer be linking 32bit binaries, and if so, how do I get a 32 bit version of this library for it to link to?

Thanks in advance!

simkine
Posts: 2
Joined: 2006/07/04 13:59:45

Re: Installing oracle10g on centos 4.3 i86_64

Post by simkine » 2006/07/04 14:02:26

I ran into this same problem. Anyone have any suggestions?

kheldar
Posts: 11
Joined: 2006/06/19 19:42:26

Re: Installing oracle10g on centos 4.3 i86_64

Post by kheldar » 2006/07/04 21:53:37

I've found an article here:

http://forums.oracle.com/forums/thread.jspa?messageID=1101776&#1101776

This recommends installing glibc-devel.i386, which has got me past this error.

However, I've got stuck at the next stage when it tries to clone a database.

I'm now getting a message ORA-12547: TNS lost contact.

Any suggestions or help would be appreciated!

simkine
Posts: 2
Joined: 2006/07/04 13:59:45

Re: Installing oracle10g on centos 4.3 i86_64

Post by simkine » 2006/07/05 14:02:46

After installing glibc-devel and libaio, I'm able to start up sqlplus.

Post Reply

Return to “CentOS 4 - Oracle Installation and Support”