Php-oci8 install recommendations

Installation and support for Oracle DB on CentOS.
Post Reply
delboy
Posts: 1
Joined: 2006/07/07 10:40:22
Contact:

Php-oci8 install recommendations

Post by delboy » 2006/07/07 17:53:49

I have successfully installed Oracle 10g (10.2.0) on Centos 4.2 and am now trying to get some old php code that uses the oci8 extensions to work. I have php 5.0.4 working fine with the Apache php module. I know I need the php-oci8 extensions installed and can find a number of links to advice on how install by rebuilding php from source, but am keen to stick to my standard yum installation methods and keep as close as possible to the Centos distro by using the Centos repos.

There is a php-oci8 rpm in the Centos 2 extras repo, and there is a long list of extension (php-**) rpms included in the release 4 Centosplus -- but the php-oci8 rpm is not there. Before I go down the ./configure route could anyone more experienced with the Centos distro give me some recommendations? I'm particularly intested to know why it disappeared from the Centos repos between release 2 and 4.

Many thanks for any advice

am3n
Posts: 3
Joined: 2005/05/09 08:52:54

Php-oci8 install recommendations

Post by am3n » 2006/08/15 07:38:38

hi there....

I have found complete list of PHP in RPM package complete with OCI8 module
can you do a trial upgrade on your box to upgrade your PHP 5.0.4-5.centos4 into php-5.0.4-8.9AX

I got the list from Miracle Linux v4.0
here's the link

[url=http://www.miraclelinux.com/update/linux/list.php?errata_id=249]http://www.miraclelinux.com/update/linux/list.php?errata_id=249[/url]

under section [MIRACLE LINUX V4.0 - Asianux Inside]
perhaps you should download all PHP package there into a folder and do

rpm -Uvh *.rpm

currently I dont have centos4 box as trial server (all are on production bcoz I trust it)
or you can download a newer version of PHP from REMI's yum repository

[url=http://remi.collet.free.fr/rpms/]http://remi.collet.free.fr/rpms/[/url]

there are no php package for centos4 but I think you can upgrade your's php version
the php module also complete
I prefer you to download php package from fc4 list.

please inform me if it is failed/succes
thx

note: Miracle Linux - Asianux Inside is based upon Red Hat Enterprise Linux.
[url=http://en.wikipedia.org/wiki/Miracle_Linux]wikipedia:miracle linux[/url]

am3n
Posts: 3
Joined: 2005/05/09 08:52:54

Re: Php-oci8 install recommendations

Post by am3n » 2006/08/16 07:11:10

hi delboy...
i hv installed php-*.rpm with all module including oci8 module from the miracle linux link in my previous post.
but when i check on phpinfo, there is no oci8 module that descripe oci8 module installed or "OCI8 Support enabled"

is there something that I missed ??

Post Reply

Return to “CentOS 4 - Oracle Installation and Support”