Page 1 of 1

PHP 4 & OCI

Posted: 2008/01/09 20:04:16
by Niniel
Is there any way to enable OCI in PHP 4 via yum or configuration files? I have found some tutorials that require configure and make commands.

I am running Centos 4, Apache 2, PHP 4, and Oracle Database Server 10g on the box. Everything works well except I cannot write PHP scripts to interface with Oracle. Any help would be appreciated. Thanks!

PHP 4 & OCI

Posted: 2008/01/10 02:55:30
by foxb
You need to recompile from source.... Rebuilding from source RPM failed for me.

Re: PHP 4 & OCI

Posted: 2008/01/21 17:51:25
by osde8info
we've also spent two days reading lots of oracle php docs and trying to compile OCI into various combinations of centos 3, 4 & 5, apache 1 & 2, php 4 & 5 so please let us know if you are successful and if so how you did it ?