operating system version: must be redhat-3, SuSE-9, redhat-4

Installation and support for Oracle DB on CentOS.
osde8info
Posts: 123
Joined: 2007/11/08 11:26:17

operating system version: must be redhat-3, SuSE-9, redhat-4

Postby osde8info » 2008/02/21 17:19:29

tried installing oracle 10g R 2 onto non red hat enterprise gnu/linux distro and got

Checking operating system version:
must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
Failed

as per

http://www.oracle-base.com/articles/10g ... nRHEL5.php

i edited /etc/redhat-release to read

redhat-4 # Enterprise Linux Enterprise Linux Server release 5.1 (Carthage)

instead and it now passes !

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

operating system version: must be redhat-3, SuSE-9, redhat-4

Postby yyagol » 2008/02/25 06:28:27

What this got to do with CentOS ? i guess you can published this on Debian/Ubuntu forums
under CentOS there is no problems installing Oracle regarding redhat-release.

osde8info
Posts: 123
Joined: 2007/11/08 11:26:17

Re: operating system version: must be redhat-3, SuSE-9, redhat-4

Postby osde8info » 2008/02/25 13:56:13

since oracle fails to install on red hat rhel 5 (& oracle unbreakable 5) i sort of assumed it would also fail to install on centos 5 ! glad to hear it works fine for you !

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

Re: operating system version: must be redhat-3, SuSE-9, redhat-4

Postby yyagol » 2008/02/25 19:01:26

Take a look on this thread by jeffreymhunter that solve this problem
http://www.centos.org/modules/newbb/vie ... 1&forum=18


osde8info
Posts: 123
Joined: 2007/11/08 11:26:17

Re: operating system version: must be redhat-3, SuSE-9, redhat-4

Postby osde8info » 2008/02/27 13:30:06

i have just got the same error (as on oracle unbreakable 5) when installing on "real" centos 5 (as predicted) !

$ ./runInstaller

Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2

Failed <<<<

Exiting Oracle Universal Installer, log for this session can be found at /tmp/OraInstall2008-02-27_01-21-54PM/installActions2008-02-27_01-21-54PM.log

so once again i just changed

$ cat /etc/redhat-release
CentOS release 5 (Final)

to read

$ cat /etc/redhat-release
redhat-4

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4&#8242;N 34 47&#8242;E
Contact:

Re: operating system version: must be redhat-3, SuSE-9, redhat-4

Postby yyagol » 2008/02/29 18:32:07

Don't thank me thanks to jeffreymhunter for sharing this link
this is what the community is all about , sharing information :-)