Problems with Yum

If it doesn't fit in another category, ask it here.
burjans
Posts: 21
Joined: 2006/09/18 14:39:53
Contact:

Problems with Yum

Postby burjans » 2006/12/12 00:32:29

When I give yum update leaves the following thing to me

Setting up Update Process
Setting up repositories
Cannot find a valid baseurl for repo: update
Error: Cannot find a valid baseurl for repo: update

Perhaps the error is that I have not formed the yum so that leaves by proxy helps me with this?

I use updated CentOS 4,3 with apt-get, but I want to learn to use the Yum

burjans
Posts: 21
Joined: 2006/09/18 14:39:53
Contact:

Re: Problems with Yum

Postby burjans » 2006/12/12 16:48:18

This message arrives me at the mail

From: "Cron Daemon"
To:
Sent: Tuesday, December 12, 2006 12:21 AM
Subject: Cron run-parts /etc/cron.daily


/etc/cron.daily/yum.cron:

Cannot find a valid baseurl for repo: update
Error: Cannot find a valid baseurl for repo: update
Cannot find a valid baseurl for repo: update

Help me

jasonxoxide
Posts: 80
Joined: 2006/09/11 14:35:48
Location: Exton, PA
Contact:

Re: Problems with Yum

Postby jasonxoxide » 2006/12/19 14:02:13

There are a few possibilities on this one.

1. Your network card isn't working. Try pinging a local network device to see if you get a response. If you do, this isn't it. If you don't, try and find the network drivers for your card and install them.
2. You haven't configured any DNS servers. Try pinging 'www.centos.org' to see if you get a response. If you don't, but you do get a response from '204.10.37.194', then you need to configure some nameservers.
3. Your network requires you to use a proxy server. In this case, you can enter your proxy details in /etc/yum.conf.

burjans
Posts: 21
Joined: 2006/09/18 14:39:53
Contact:

Re: Problems with Yum

Postby burjans » 2006/12/22 15:51:45

Everything seems to indicate that I cannot use together the Yum and the Apt. The Apt works correctly just as synaptic

hpaterek
Posts: 1
Joined: 2007/01/29 08:31:51

Re: Problems with Yum

Postby hpaterek » 2007/01/29 08:38:14

It is important you put a / after the proxy definition in proxy.conf. This is not documented!

thus:

proxy.conf:

proxy=http://proxy.server.here:port/