Time Slipping with CentOS VMWARE client

If it doesn't fit in another category, ask it here.
User avatar
toracat
Forum Moderator
Posts: 7230
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby toracat » 2008/05/26 07:28:27

Sorry, I did not make it clear. By "all 3 open-vm-tools-xxx rpms" I meant these three packages:

open-vm-tools-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm

which are found in http://people.centos.org/hughesjr/open-vm-tools/4/i386/ . You've already downloaded:

kmod-open-vm-tools-0-0.20080502.2.6.9_67.0.7.EL.i686.rpm

Put the above 4 rpms (and only those 4) in a directory and issue this command:

rpm -Uvh *

That should install the 4 rpms without any dependency problem.

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/26 08:45:38

[root@ns1 work]# dir
open-vm-tools-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm
[root@ns1 work]# rpm -Uvh *
error: Failed dependencies:
open-vm-tools-kmod >= 0 is needed by open-vm-tools-0-0.20080502.el4.centos.i386
libatk-1.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libgdk-x11-2.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libgdk_pixbuf-2.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libgtk-x11-2.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libpango-1.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libpangox-1.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
libpangoxft-1.0.so.0 is needed by open-vm-tools-gtk-0-0.20080502.el4.centos.i386
[root@ns1 work]#

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/26 08:50:11

Again thanks for you help! I am glad to pay for you to fix this if you think it can be. I don't mind working with you for free either.. This is a centOS load from: http://www.nuonce.net/bluequartz.php

I have contacted them and they do not support their buildout on VMWare. He was very nice and understand his postion. Every aspect of this system is great except for the exceptional loss in time. One week in real life is equal to one day on the system. I believe that this can work, and somewhat regret using this modified version of a Raq550 OS due to this one problem, but I am stuck with it for now. :(

User avatar
toracat
Forum Moderator
Posts: 7230
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby toracat » 2008/05/26 13:15:44

I wish you get this working, too. But you need to read my notes carefully. I wrote "Put the above 4 rpms". The "4 rpms" would have included the kmod-open-vm-tools rpm. One of the errors you saw was because this rpm was lacking in your directory.

Because you also have another issue, I now suggest the following. Put these four rpm files in a directory (and nothing else):

open-vm-tools-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm
kmod-open-vm-tools-0-0.20080502.2.6.9_67.0.7.EL.i686.rpm

and try this command:

yum localinstall *

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/27 03:56:12

[root@ns1 james]# dir
kmod-open-vm-tools-0-0.20080502.2.6.9_67.0.7.EL.i686.rpm
open-vm-tools-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm
open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm
[root@ns1 james]#
[root@ns1 james]# yum localinstall *
Setting up Local Package Process
Examining kmod-open-vm-tools-0-0.20080502.2.6.9_67.0.7.EL.i686.rpm: kmod-open-vm-tools - 0-0.20080502.2.6.9_67.0.7.EL.i686
Examining open-vm-tools-0-0.20080502.el4.centos.i386.rpm: open-vm-tools - 0-0.20080502.el4.centos.i386
Examining open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm: open-vm-tools-common - 0-0.20080502.el4.centos.i386
Examining open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm: open-vm-tools-gtk - 0-0.20080502.el4.centos.i386
Marking kmod-open-vm-tools-0-0.20080502.2.6.9_67.0.7.EL.i686.rpm to be installed
Marking open-vm-tools-0-0.20080502.el4.centos.i386.rpm to be installed
Marking open-vm-tools-common-0-0.20080502.el4.centos.i386.rpm to be installed
Marking open-vm-tools-gtk-0-0.20080502.el4.centos.i386.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package open-vm-tools-common.i386 0:0-0.20080502.el4.centos set to be updated
---> Package open-vm-tools-gtk.i386 0:0-0.20080502.el4.centos set to be updated
---> Package kmod-open-vm-tools.i686 0:0-0.20080502.2.6.9_67.0.7.EL set to be updated
---> Package open-vm-tools.i386 0:0-0.20080502.el4.centos set to be updated
--> Running transaction check
Setting up repositories
http://www.nuonce.net/repos/repodata/repomd.xml: [Errno 4] IOError:
Trying other mirror.
Cannot open/read repomd.xml file for repository: NuOnce Networks
failure: repodata/repomd.xml from NuOnce Networks: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from NuOnce Networks: [Errno 256] No more mirrors to try.
[root@ns1 james]#

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/27 04:13:56

Ok, I researched and found this could be a DNS problem on the yum error. I added 127.0.0.0/24 to the allowed lookup list and the yum is working now. I got a Complete after running your command. What now?

Transaction Summary
=============================================================================
Install 8 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 6.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): gtk2-2.4.13-22.i38 100% |=========================| 4.3 MB 00:06
(2/4): pango-1.6.0-9.i386 100% |=========================| 271 kB 00:00
(3/4): libtiff-3.6.1-12.i 100% |=========================| 257 kB 00:00
(4/4): atk-1.8.0-2.i386.r 100% |=========================| 170 kB 00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: atk ######################### [1/8]
Installing: pango ######################### [2/8]
Installing: libtiff ######################### [3/8]
Installing: gtk2 ######################### [4/8]
Installing: open-vm-tools-common ######################### [5/8]
Installing: open-vm-tools ######################### [6/8]
Installing: open-vm-tools-gtk ######################### [7/8]
Installing: kmod-open-vm-tools ######################### [8/8]

Installed: kmod-open-vm-tools.i686 0:0-0.20080502.2.6.9_67.0.7.EL open-vm-tools.i386 0:0-0.20080502.el4.centos open-vm-tools-common.i386 0:0-0.20080502.el4.centos open-vm-tools-gtk.i386 0:0-0.20080502.el4.centos
Dependency Installed: atk.i386 0:1.8.0-2 gtk2.i386 0:2.4.13-22 libtiff.i386 0:3.6.1-12 pango.i386 0:1.6.0-9
Complete!
[root@ns1 james]#
[root@ns1 james]#

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/27 05:43:13

Ok after some looking around... And you helping me with the Yum, I was able to get the VMWARE tools installed from my workstation disc. With the expermental cpu deal it has it seems to be keeping to clock much more updated. I will update after a couple of hours to let you know if it worked. It seems like it might still be a hair slow.. but at least it's in the ball park now.

User avatar
toracat
Forum Moderator
Posts: 7230
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby toracat » 2008/05/27 06:56:01

Glad to hear you could install vmware tools. I suppose you then enabled host time synchronization? Let us know how you clock behaves now.

mrcool
Posts: 11
Joined: 2008/05/23 21:39:35
Contact:

Re: Time Slipping with CentOS VMWARE client

Postby mrcool » 2008/05/28 01:29:08

So about 24 hours into it and it's spot on. Kudos for the help. I just enabled everything the vmware install script offered. At first there were two options that were "Experimental" I did not enable those and the time still slipped. I did another install and enabled those two options and it works like a charm! :)