problem in making clustering in centos 4.8....

If it doesn't fit in another category, ask it here.
amitmanisingh
Posts: 1
Joined: 2010/12/22 17:05:10

problem in making clustering in centos 4.8....

Postby amitmanisingh » 2010/12/22 18:07:39

hello frnds....

i am implementing cluster with two linux systems having centos 4.8
and i implemented the cluster manager on one system(node 1) and all the services
are running well on that system....

#service ccsd start
#service cman start
#service clvmd start
#service rgmanager start.....

after that i want to add the other system (or node 2) to the first
system (node1) as a member of cluster....
for this,i am adding the node in cluster configuraion tool on left
side option of cluster nodes and do all the configuraion for that
node(node 2).

After this i stopped all the services of node1 and copy the cluster
configuration file(/etc/cluster/cluster.conf) using scp command to other node(node 2)
and restart all the services on both nodes node1 and node2.

All services started on node1 but no services started on node2 (except ccsd) in which i copied the
cluster conf. file and gives an errror.....

#service ccsd start.......[OK]
#service cman start.......[FAILED]
#service clvmd start......[FAILED]
#service rgmanager start.....[FAILED]

and also shows the error could not connect to the cluster manager

when I saw the status of cluster using....
#clustat

it shows....

Mamber status: Quorate
Member Name status
node1 Online,Local,rgmanager
node2 Offline

So any one tell me where i'm doing mistake in adding the node or
is there any other problem in implementing the cluster.

please reply as soon as possible......

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

problem in making clustering in centos 4.8....

Postby gerald_clark » 2010/12/22 22:13:07

I would recommend CentOS 5.5 over 4.8 for any new projects.
4.8 is getting pretty long in the tooth.