CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

General support questions
badassmexican
Posts: 4
Joined: 2017/03/20 20:32:37

CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby badassmexican » 2017/03/20 20:57:09

Hi,

I have a Lenovo ThinkServer RD340 and CentOS 6.8 installs fine. It sees the hard drive as a BIOS raid. When I try to install CentOS 7 it doesn't see the hard drive.

Is there any way for me to use this machine with 7? Is a driver missing that I can add during install?

The BIOS shows it as an LSI RAID but it comes up as Intel I think.

Here is the output from my machine when 6.8 is installed:
(Let me know if I should look at other commands output)

[root@localhost ait]# lspci -nn | grep SCSI
03:00.0 Serial Attached SCSI controller [0107]: Intel Corporation C606 chipset Dual 4-Port SATA/SAS Storage Control Unit [8086:1d68] (rev 06)
[root@localhost ait]# grep -i 1d68 /lib/modules/2.6.32-642.el6.x86_64/modules.* | grep -i 8086
/lib/modules/2.6.32-642.el6.x86_64/modules.alias:alias pci:v00008086d00001D68sv*sd*bc*sc*i* isci
/lib/modules/2.6.32-642.el6.x86_64/modules.pcimap:isci 0x00008086 0x00001d68 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0

filename: /lib/modules/2.6.32-642.el6.x86_64/kernel/drivers/scsi/isci/isci.ko
firmware: isci/isci_firmware.bin
license: Dual BSD/GPL
version: 1.1.0-rh
srcversion: 0733B584E2727CD2D6A4F6B
alias: pci:v00008086d00001D6Asv*sd*bc*sc*i*
alias: pci:v00008086d00001D68sv*sd*bc*sc*i*
alias: pci:v00008086d00001D66sv*sd*bc*sc*i*
alias: pci:v00008086d00001D64sv*sd*bc*sc*i*
alias: pci:v00008086d00001D62sv*sd*bc*sc*i*
alias: pci:v00008086d00001D60sv*sd*bc*sc*i*
alias: pci:v00008086d00001D6Bsv*sd*bc*sc*i*
alias: pci:v00008086d00001D69sv*sd*bc*sc*i*
alias: pci:v00008086d00001D67sv*sd*bc*sc*i*
alias: pci:v00008086d00001D65sv*sd*bc*sc*i*
alias: pci:v00008086d00001D63sv*sd*bc*sc*i*
alias: pci:v00008086d00001D61sv*sd*bc*sc*i*
depends: libsas,scsi_transport_sas
vermagic: 2.6.32-642.el6.x86_64 SMP mod_unload modversions
parm: no_outbound_task_to:No Outbound Task Timeout (1us incr) (byte)
parm: ssp_max_occ_to:SSP Max occupancy timeout (100us incr) (ushort)
parm: stp_max_occ_to:STP Max occupancy timeout (100us incr) (ushort)
parm: ssp_inactive_to:SSP inactivity timeout (100us incr) (ushort)
parm: stp_inactive_to:STP inactivity timeout (100us incr) (ushort)
parm: phy_gen:PHY generation (1: 1.5Gbps 2: 3.0Gbps 3: 6.0Gbps) (byte)
parm: max_concurr_spinup:Max concurrent device spinup (byte)
parm: cable_selection_override:This field indicates length of the SAS/SATA cable between host and device. If any bits > 15 are set (default) indicates "use platform defaults" (uint)


Thank,
Joel

User avatar
TrevorH
Forum Moderator
Posts: 19457
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby TrevorH » 2017/03/20 22:02:41

Try switching to console 2 (Ctrl-Alt-F2) and run modprobe isci then dmesg to see the last few lines of the log and see if it says anything useful as it loads.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

badassmexican
Posts: 4
Joined: 2017/03/20 20:32:37

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby badassmexican » 2017/03/21 00:08:43

Here's what I saw when I ran dmesg. Sorry about using an image but I couldn't copy it or get it off the machine.

Screen Shot 2017-03-20 at 5.06.07 PM.png
Screen Shot 2017-03-20 at 5.06.07 PM.png (124.66 KiB) Viewed 200 times

badassmexican
Posts: 4
Joined: 2017/03/20 20:32:37

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby badassmexican » 2017/03/21 00:48:15

Here is the full output of the last lines. I couldn't upload the image so I linked it.


Image

User avatar
TrevorH
Forum Moderator
Posts: 19457
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby TrevorH » 2017/03/21 07:25:29

That 'oprom parse error' looks like a hardware problem to me. Is there any data on this controller - perhaps you could do a reset to factory defaults and see if that fixes it?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

badassmexican
Posts: 4
Joined: 2017/03/20 20:32:37

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby badassmexican » 2017/03/21 19:04:13

There is no data on the machine. I set the BIOS to defaults and reset the BIOS raid. It still doesn't install 7. 6.8 still installs. Any other ideas? Is something missing from 7 that was in 6.8?

User avatar
TrevorH
Forum Moderator
Posts: 19457
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 doesn't see HD and CentOS 6.8 does. How do I add what's missing to the install?

Postby TrevorH » 2017/03/21 19:52:22

I don't think it's anything missing, if anything it would appear to be some extra validity checking that's taking place that makes it think the controller is not well.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke


Return to “CentOS 7 - General Support”

Who is online

Users browsing this forum: No registered users and 2 guests