Booted with XEN kernel

General support questions
rookie
Posts: 3
Joined: 2013/11/05 10:39:55

Booted with XEN kernel

Postby rookie » 2017/11/09 07:28:41

Hi:

I tried to boot the xen kernel-4.9.58-29.el7.x86_64 on a Dell R410(Xeon E5606) with UEFI,
but after selected it in boot menu, it hanged.
(I didn't install xen yet, just install kernel 4.9.58 to make sure if it can work.)
I reboot and cat the /var/log/message, see the message in the last:

Code: Select all

Nov  9 14:47:04 localhost systemd: Started LSB: Bring up/down networking.
Nov  9 14:47:04 localhost systemd: Reached target Network.
Nov  9 14:47:04 localhost systemd: Starting Network.
Nov  9 14:47:04 localhost systemd: Reached target Network is Online.
Nov  9 14:47:04 localhost systemd: Starting Network is Online.
Nov  9 14:47:04 localhost systemd: Starting Dynamic System Tuning Daemon...
Nov  9 14:47:04 localhost systemd: Starting OpenSSH server daemon...
Nov  9 14:47:04 localhost systemd: Starting Postfix Mail Transport Agent...
Nov  9 14:47:04 localhost systemd: Started OpenSSH server daemon.
Nov  9 14:47:04 localhost systemd: Started Dynamic System Tuning Daemon.
Nov  9 14:47:05 localhost systemd: Started Postfix Mail Transport Agent.
Nov  9 14:47:05 localhost systemd: Reached target Multi-User System.
Nov  9 14:47:05 localhost systemd: Starting Multi-User System.
Nov  9 14:47:05 localhost systemd: Started Stop Read-Ahead Data Collection 10s After Completed Startup.
Nov  9 14:47:05 localhost systemd: Starting Stop Read-Ahead Data Collection 10s After Completed Startup.
Nov  9 14:47:05 localhost systemd: Starting Update UTMP about System Runlevel Changes...
Nov  9 14:47:05 localhost systemd: Started Update UTMP about System Runlevel Changes.
Nov  9 14:47:05 localhost systemd: Startup finished in 2.161s (kernel) + 19.670s (initrd) + 18.481s (userspace) = 40.313s.
Nov  9 14:47:35 localhost systemd: Starting Stop Read-Ahead Data Collection...
Nov  9 14:47:35 localhost systemd: Started Stop Read-Ahead Data Collection.


How can I do?

Thank you

rookie
Posts: 3
Joined: 2013/11/05 10:39:55

Re: Booted with XEN kernel

Postby rookie » 2017/11/15 02:57:44

Used kernel-4.9.58-29 to boot is ok, just no console, must login from remote.
but after install xen, grub2-efi-x64-modules and link /usr/lib/grub/x86_64-efi to /boot/efi/EFI/centos,
then boot with xen xen kernel, it will reboot self, can't into xen hyper...

rookie
Posts: 3
Joined: 2013/11/05 10:39:55

Re: Booted with XEN kernel

Postby rookie » 2017/11/22 06:27:05

I install CentOS 7 in other R410 with bios mode, can boot with kernel 4.9,
but after install xen, still reboot self with xen hyper kernel.
so, I can't use CentOS XEN on Dell R410...