[Solved] Any way to test why my laptop's CPU is running hot?

General support questions
Post Reply
User avatar
Fufu
Posts: 16
Joined: 2014/07/08 09:35:44

[Solved] Any way to test why my laptop's CPU is running hot?

Post by Fufu » 2014/07/12 02:07:09

Any way to find out why my laptop's CPU is running hot?

Under CentOS 7, my laptop is burning hot. Any suggestions on how to troubleshoot in CentOS, besides altering the laptop's outside environment?
Last edited by Fufu on 2014/07/13 03:58:20, edited 1 time in total.
KDE | 3.10.0-123.4.2.el7.x86_64 | Fujitsu T901 | nVidia NVS 4200M | Intel i7-2640M 2.8GHz | 16GB | SSD
CentOS 7: Step-by-step solution for nVidia NVS Optimus drivers

nbritton
Posts: 38
Joined: 2014/07/09 23:38:46

Re: Any way to test why my laptop's CPU is running hot?

Post by nbritton » 2014/07/12 03:04:13

The cpupower command. https://access.redhat.com/site/document ... index.html

[root@localhost network-scripts]# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0 2
CPUs which need to have their frequency coordinated by software: 0 2
maximum transition latency: 10.0 us.
hardware limits: 2.00 GHz - 2.50 GHz
available frequency steps: 2.50 GHz, 2.00 GHz
available cpufreq governors: conservative, userspace, powersave, ondemand, performance
current policy: frequency should be within 2.00 GHz and 2.50 GHz.
The governor "ondemand" may decide which speed to use
within this range.
current CPU frequency is 2.00 GHz (asserted by call to hardware).
boost state support:
Supported: no
Active: no

[root@localhost network-scripts]# cpupower frequency-set --governor conservative
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
Setting cpu: 4
Setting cpu: 5
Setting cpu: 6
Setting cpu: 7

[root@localhost network-scripts]# cpupower set --perf-bias 15
Segmentation fault (core dumped)

[root@localhost network-scripts]# cpupower monitor
|Mperf || Idle_Stats
PKG |CORE|CPU | C0 | Cx | Freq || POLL | C1 | C2 | C3
0| 0| 0| 0.08| 99.92| 1990|| 0.00| 0.00| 71.72| 28.22
0| 1| 2| 0.04| 99.96| 2006|| 0.00| 0.00| 99.70| 0.27
0| 2| 4| 0.23| 99.77| 1999|| 0.00| 0.00| 96.82| 2.98
0| 3| 6| 2.69| 97.31| 1999|| 0.00| 0.03| 96.77| 0.67
1| 0| 1| 0.04| 99.96| 2002|| 0.00| 0.00| 82.65| 17.32
1| 1| 3| 0.04| 99.96| 2007|| 0.00| 0.00| 99.02| 0.95
1| 2| 5| 0.05| 99.95| 1994|| 0.00| 0.00| 99.74| 0.22
1| 3| 7| 0.15| 99.85| 1999|| 0.00| 0.00| 97.84| 2.03

User avatar
Fufu
Posts: 16
Joined: 2014/07/08 09:35:44

Re: Any way to test why my laptop's CPU is running hot?

Post by Fufu » 2014/07/12 10:57:11

Thank you for the link. **bookmarked**

Here is my output when I ran the same commands in konsole.

Code: Select all

[root@localhost Downloads]# cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 3.50 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 3.50 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.32 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes
    3300 MHz max turbo 4 active cores
    3300 MHz max turbo 3 active cores
    3300 MHz max turbo 2 active cores
    3500 MHz max turbo 1 active cores
[root@localhost Downloads]# cpupower frequency-set --governor conservative
Setting cpu: 0
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?
[root@localhost Downloads]# cpupower monitor
    |Nehalem                    || SandyBridge        || Mperf              || Idle_Stats                              
CPU | C3   | C6   | PC3  | PC6  || C7   | PC2  | PC7  || C0   | Cx   | Freq || POLL | C1-S | C1E- | C3-S | C6-S | C7-S 
   0|  2.30|  0.00|  2.09| 22.12|| 74.26| 16.86| 17.57||  5.95| 94.05|  2633||  0.00|  2.00|  7.07|  2.71|  0.00| 82.03
   1|  2.30|  0.00|  2.09| 22.12|| 74.26| 16.86| 17.57||  5.79| 94.21|  3164||  0.00|  2.58|  2.78|  0.36|  0.00| 88.27
   2|  2.64|  0.84|  2.09| 22.12|| 75.46| 16.86| 17.57||  8.73| 91.27|  2219||  0.00|  0.61|  2.77|  1.21|  0.48| 85.81
   3|  2.64|  0.84|  2.09| 22.12|| 75.46| 16.86| 17.57||  3.18| 96.82|  2979||  0.00|  3.96|  0.39|  2.04|  0.47| 89.68
Suggestions?
KDE | 3.10.0-123.4.2.el7.x86_64 | Fujitsu T901 | nVidia NVS 4200M | Intel i7-2640M 2.8GHz | 16GB | SSD
CentOS 7: Step-by-step solution for nVidia NVS Optimus drivers

nbritton
Posts: 38
Joined: 2014/07/09 23:38:46

Re: Any way to test why my laptop's CPU is running hot?

Post by nbritton » 2014/07/12 16:02:56

Fufu wrote: Here is my output when I ran the same commands in konsole.

Code: Select all

[root@localhost Downloads]# cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 3.50 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 3.50 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.32 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes
    3300 MHz max turbo 4 active cores
    3300 MHz max turbo 3 active cores
    3300 MHz max turbo 2 active cores
    3500 MHz max turbo 1 active cores
[/quote]

Your cpupower governor is set to performance, this means turbo mode is activated. That's why it's so hot. Your system apparently only has two governors to choose from, it only offers you performance or powersave. Run "cpupower frequency-set --governor powersave" and see how you like that.

User avatar
Fufu
Posts: 16
Joined: 2014/07/08 09:35:44

Re: Any way to test why my laptop's CPU is running hot?

Post by Fufu » 2014/07/13 03:57:13

Thanks for the explanation.
Now I am able govern/create additional plans.
I see what you did. I only have two plans to govern after comparing my terminal with yours.

Code: Select all

[root@localhost kk]# cpupower frequency-set --governor powersave
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
[root@localhost kk]# cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 3.50 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 3.50 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency is 1.35 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes
    3300 MHz max turbo 4 active cores
    3300 MHz max turbo 3 active cores
    3300 MHz max turbo 2 active cores
    3500 MHz max turbo 1 active cores
[root@localhost kk]# cpupower monitor
    |Nehalem                    || SandyBridge        || Mperf              || Idle_Stats                              
CPU | C3   | C6   | PC3  | PC6  || C7   | PC2  | PC7  || C0   | Cx   | Freq || POLL | C1-S | C1E- | C3-S | C6-S | C7-S 
   0|  2.84|  0.01|  0.20| 12.05|| 77.53|  8.96| 27.10||  4.06| 95.94|  1531||  0.00|  1.69|  3.02|  1.78|  0.01| 89.19
   1|  2.84|  0.01|  0.20| 12.05|| 77.53|  8.96| 27.10||  4.40| 95.60|  1864||  0.00|  5.55|  1.20|  0.43|  0.00| 88.30
   2|  0.90|  0.00|  0.20| 12.05|| 78.43|  8.96| 27.10||  7.73| 92.27|  1852||  0.00|  0.17|  1.20|  0.33|  0.00| 90.34
   3|  0.90|  0.00|  0.20| 12.05|| 78.43|  8.96| 27.10||  4.02| 95.98|  1903||  0.00|  0.00|  8.62|  0.15|  0.00| 87.05
KDE | 3.10.0-123.4.2.el7.x86_64 | Fujitsu T901 | nVidia NVS 4200M | Intel i7-2640M 2.8GHz | 16GB | SSD
CentOS 7: Step-by-step solution for nVidia NVS Optimus drivers

Post Reply

Return to “CentOS 7 - General Support”