TigerVNCServer configuration

General support questions
Post Reply
rss245
Posts: 3
Joined: 2015/03/23 22:23:01

TigerVNCServer configuration

Post by rss245 » 2015/03/23 23:24:31

I do not believe I am having the same problem and as I have done a a number of things trying to follow the instructions laid out
TigerVNCServer is rather a challenging service to get running.

I really wish there was a more up to date version of documentation for CentOS 7

Basically I followed the instructions from the wiki which includes editing:
/etc/systemd/system/vncserver@:1.service file

Assumptions made: <display> is 1 for first user allowed to use VNC
<USER> is one of the users allowed to use VNC e.g joe
All 4 below steps were done.
I also added the allowance in the iptables file to allow 4 ports access.
When I try to start the service I get:
[root@localhost sysconfig]# service vncserver start
Redirecting to /bin/systemctl start vncserver.service
Failed to issue method call: Unit vncserver.service failed to load: No such file or directory.

Also when I run:
[root@localhost sysconfig]# rpm -q tigervnc-server-1.2.80-0.30.20130314svn5065.el7
tigervnc-server-1.2.80-0.30.20130314svn5065.el7.x86_64

says its installed?

If I do a find / -name "*vnc*" -print
I am not finding any vnc files other than a perl script at /usr/bin/vncserver
Any help on this issue would be appreciated
e.g
# The vncserver service unit file
#
# Quick HowTo:
# 1. Copy this file to /etc/systemd/system/vncserver@:<display>.service
# 2. Edit <USER> and vncserver parameters appropriately
# ("runuser -l <USER> -c /usr/bin/vncserver %i -arg1 -arg2")
# 3. Run `systemctl daemon-reload`
# 4. Run `systemctl enable vncserver@:<display>.service`
#
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted! For a secure way of using VNC, you should
# limit connections to the local host and then tunnel from
# the machine you want to view VNC on (host A) to the machine
# whose VNC output you want to view (host B)
#
# [user@hostA ~]$ ssh -v -C -L 590N:localhost:590M hostB
#
# this will open a connection on port 590N of your hostA to hostB's port 590M
# (in fact, it ssh-connects to hostB and then connects to localhost (on hostB).
# See the ssh man page for details on port forwarding)
#
# You can then point a VNC client on hostA at vncdisplay N of localhost and with
# the help of ssh, you end up seeing what hostB makes available on port 590M
#
# Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.
#
# Use "-localhost" to prevent remote VNC clients connecting except when
# doing so through a secure tunnel. See the "-via" option in the
# `man vncviewer' manual page.


[Unit]
Description=Remote desktop service (VNC)
After=syslog.target network.target

[Service]
Type=forking
"/etc/systemd/system/vncserver@:1.service"

User avatar
TrevorH
Forum Moderator
Posts: 23897
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: TigerVNCServer configuration

Post by TrevorH » 2015/03/23 23:32:08

I've split your post away from the topic you posted to as it was over two years old and related to CentOS 6 and you are on 7. I've also moved it to the correct forum.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

rss245
Posts: 3
Joined: 2015/03/23 22:23:01

Re: TigerVNCServer configuration

Post by rss245 » 2015/03/24 02:36:40

thank you !

Have you gotten vnc server running on CentOS 7. Just how new is this Operating System?

stephenw
Posts: 15
Joined: 2015/02/19 17:46:27

Re: TigerVNCServer configuration

Post by stephenw » 2015/03/24 07:50:59

You do not need the display number in the configuration file's name. You only need that when you start the service. Try the instructions in the RHEL7 System Administrator's Guide here:TigerVNC.

Post Reply