Centos 7 update require kernel >= 3.10.0-229.el7

General support questions
Post Reply
raffaele.fabbri
Posts: 77
Joined: 2015/03/14 07:57:15

Centos 7 update require kernel >= 3.10.0-229.el7

Post by raffaele.fabbri » 2015/03/24 20:04:56

I try to update my centos7 with command
sudo yum update
and the result is
Elaborazione dipendenza: kernel >= 3.10.0-229.el7 per il pacchetto: kmod-rts5139-1.04-2.el7.elrepo.x86_64
I attach the log file

somebody can help me?

thanks
Raffaele
Attachments
update.txt
(3.64 KiB) Downloaded 45 times

User avatar
TrevorH
Forum Moderator
Posts: 23876
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 7 update require kernel >= 3.10.0-229.el7

Post by TrevorH » 2015/03/24 20:13:49

You have the ELRepo yum repository enabled and they have published some packages in preparation for 7.1 that have a Require: for the 7.1 kernel. You can either enable the CentOS CR repo and gain early access to what will be 7.1 when it's released or you can exclude the package that is causing the problem (kmod-rts5139) or disable the ELRepo repository.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

raffaele.fabbri
Posts: 77
Joined: 2015/03/14 07:57:15

Re: Centos 7 update require kernel >= 3.10.0-229.el7

Post by raffaele.fabbri » 2015/03/25 20:27:31

I try to disable elrepo
yum clean all
yum update
and nothing to update

-rw-r--r-- 1 root root 1664 20 feb 15.38 CentOS-Base.repo
-rw-r--r-- 1 root root 1309 20 feb 15.38 CentOS-CR.repo
-rw-r--r-- 1 root root 649 20 feb 15.38 CentOS-Debuginfo.repo
-rw-r--r-- 1 root root 290 20 feb 15.38 CentOS-fasttrack.repo
-rw-r--r-- 1 root root 1331 20 feb 15.38 CentOS-Sources.repo
-rw-r--r-- 1 root root 156 20 feb 15.38 CentOS-Vault.repo
-rw-r--r-- 1 root root 158 2 dic 21.57 dropbox.repo
-rw-r--r-- 1 root root 2150 21 mag 2014 elrepo.repo.disable
-rw-r--r-- 1 root root 957 25 nov 17.23 epel.repo
-rw-r--r-- 1 root root 1056 25 nov 17.23 epel-testing.repo
-rw-r--r--. 1 root root 116 3 nov 20.13 google-chrome.repo
-rw-r--r--. 1 root root 477 31 lug 2014 nux-dextop.repo
-rw-r--r-- 1 root root 257 25 mar 20.41 virtualbox.repo
and now no error
thanks

Post Reply