Problem while cloning CentOS 7 VM

General support questions
Posts: 3
Joined: 2013/01/09 09:46:56

Re: Problem while cloning CentOS 7 VM

Post by RolandS » 2016/04/28 15:20:25

sefsupport wrote:Appreciate all the advise from both of aks, Jeremy and waishingleung.

I have given up trying to resolve the problems and re-install everything from scratch on the Hyper-V vm instead. This could post a really bad problem when we try to recover the systems from a HD replacement for a physical server. Somebody need to derive a good solution to this.
I had the same error when messing with VM and virtual IDE/SATA/SCSI controllers on an existing installation.
Its seems that the initramfs has to be rebuilt, and maybe the grub2 config too.
Try this it worked for me :

PS : if you have several kernel installed be careful that the grub2 config and the initramfs generated match the correct kernel* files and versions.

Posts: 1
Joined: 2016/06/21 15:59:22

Re: Problem while cloning CentOS 7 VM

Post by danielarend » 2016/06/21 16:05:10

I faced the same problem yesterday. I fixed it on disc settings by removing the SATA controller (default) and installed a SAS controller, and then attach the VMDK file again. Worked for me!

Post Reply