HTTPD service wont start

General support questions
broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

HTTPD service wont start

Post by broccoli » 2015/07/20 12:46:46

Hello,

I am kinda new to Linux (centos), and i am trying to install apache on my linux terminal server. But the service HTTPD wont start.
Here is a log of journalctl -xn. If there is someone out there that can help me, please do!

Code: Select all

[root@localhost ~]# journalctl -xn
-- Logs begin at sø. 2015-07-19 23:55:56 CEST, end at ma. 2015-07-20 00:09:32 CEST. --
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992295 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992304 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992309 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992316 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
juli 20 00:09:32 localhost.apilix systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
juli 20 00:09:32 localhost.apilix kill[2661]: kill: cannot find process ""
juli 20 00:09:32 localhost.apilix systemd[1]: httpd.service: control process exited, code=exited status=1
juli 20 00:09:32 localhost.apilix systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit httpd.service has failed.
--
-- The result is failed.
juli 20 00:09:32 localhost.apilix systemd[1]: Unit httpd.service entered failed state.


Thanks

aks
Posts: 2567
Joined: 2014/09/20 11:22:14

Re: HTTPD service wont start

Post by aks » 2015/07/20 17:00:43

juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992295 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992304 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992309 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992316 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier A
Have a look at the file mentioned - is there something wrong with those lines?
juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
HTTPD can't start there's already something using tcp/80 - are you trying to start Apache when it's already running?

YOu could have a look at https://www.digitalocean.com/community/ ... s-80-error

aks
Posts: 2567
Joined: 2014/09/20 11:22:14

Re: HTTPD service wont start

Post by aks » 2015/07/20 17:05:22

Also are you starting httpd as root?

broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

Re: HTTPD service wont start

Post by broccoli » 2015/07/20 17:29:23

I cant stop/restart/start HTTPD same error. I will look at the port to see if i can find something out, and yes i use root when i try to start it, i jused putty to copy the error.

broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

Re: HTTPD service wont start

Post by broccoli » 2015/07/20 21:40:33

Well ok i have cheked and done allot, i finaly got it up and running,
Now the only thing is that i cant get it public, like i cant acces the url/ip from my web browser. How can i do that, I am using CentOs 7, and i have opened the ports in the firewall using the following command

Code: Select all

firewall-cmd --permanent --zone=<zone> --add-port=8080-8080/tcp
as showen on the image's
Image
Image,


Image shows wrong, It is enabled not disabled.

User avatar
TrevorH
Forum Moderator
Posts: 24078
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: HTTPD service wont start

Post by TrevorH » 2015/07/20 21:44:55

You need to run firewall-cmd twice, once with --permanent and once without it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

Re: HTTPD service wont start

Post by broccoli » 2015/07/20 21:51:16

This dident work for me since i have already done that... I also tryed to use

Code: Select all

firewall-cmd --reload
, to reload it but it dient work..

broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

Re: HTTPD service wont start

Post by broccoli » 2015/07/20 21:53:25

I checked the status of the service firewalld, idk if this is how it shuld look like. Problery someone that can explain? and or give me info to fix the red text.

Image

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: HTTPD service wont start

Post by gerald_clark » 2015/07/20 21:55:14

1. You don't need to specify the port twice if it is not a range.
2. Httpd uses port 80 by default, not port 8080.

broccoli
Posts: 9
Joined: 2015/07/20 12:45:00

Re: HTTPD service wont start

Post by broccoli » 2015/07/20 21:56:12

I have been in the config and edited it to 8080, but i can change it back to 80 if that works bether ?

Post Reply