Indirect GLX rendering CentOS 7.2

General support questions
Post Reply
larsli
Posts: 3
Joined: 2016/04/13 08:56:44

Indirect GLX rendering CentOS 7.2

Post by larsli » 2016/04/13 09:14:28

After updating to CentOS 7.2, our legacy OpenGL software will no longer start. It just fails with error message: 21 :BadValue (Integer parameter out of range for operation...)

I understand that this has to do with indirect GLX rendering not allowed by default. I have tried to set: Option "AllowIndirectGLXProtocol" "True" in xorg.conf, but that doesn't seem to help. The only way I can get the software to start is to manually run startx -- +iglx

How can I enable this without having to start X manually? (I have Nvidia drivers installed.)

L3G0
Posts: 3
Joined: 2014/10/19 15:16:24

Re: Indirect GLX rendering CentOS 7.2

Post by L3G0 » 2016/05/18 14:20:30

I've got the exactly same Problem because i installed the nvidia driver.

I tryed adding tihs to /etc/X11/xorg.conf.d/99-nvidia.conf but ended up with an not starting Xorg

Code: Select all

Section "Screen"
        Option "AllowIndirectGLXProtocol" "true"
EndSection
Edit:
The question is, does this still work?
http://tldp.org/HOWTO/XFree-Local-multi ... f-gdm.html

maxxdesktop
Posts: 6
Joined: 2016/05/17 14:34:24

Re: Indirect GLX rendering CentOS 7.2

Post by maxxdesktop » 2016/05/18 14:42:40

larsli wrote:After updating to CentOS 7.2, our legacy OpenGL software will no longer start. It just fails with error message: 21 :BadValue (Integer parameter out of range for operation...)

I understand that this has to do with indirect GLX rendering not allowed by default. I have tried to set: Option "AllowIndirectGLXProtocol" "True" in xorg.conf, but that doesn't seem to help. The only way I can get the software to start is to manually run startx -- +iglx

How can I enable this without having to start X manually? (I have Nvidia drivers installed.)
Might be related to the newest NV driver... Have you tried to use the 340 branch?

On which glx command it fails?

Also, what's the output of glxinfo and xdpyinfo are telling you?

L3G0
Posts: 3
Joined: 2014/10/19 15:16:24

Re: Indirect GLX rendering CentOS 7.2

Post by L3G0 » 2016/05/24 12:53:45

maxxdesktop wrote:
larsli wrote:Might be related to the newest NV driver... Have you tried to use the 340 branch?
The problem are changed default values in the Xorg Server that shipped with CentOS 7.2 ...

An usefull workarround would be to tell GDM to run the Xorg with the +iglx flag, but i cant find any config to append this flag. :cry:

one idea is to create an wrapper Xorg executable:

Code: Select all

mv /usr/bin/Xorg /usr/bin/Xorg.original
echo -e '#!/usr/bin/env bash\nexec /usr/bin/Xorg.original "$@" +iglx' > /usr/bin/Xorg
chmod +x /usr/bin/Xorg
chcon --type=bin_t /usr/bin/Xorg
Will test it tomorrow, but it is still just an work around...

Update:
It works wonderful, but maybe there is an additional step necessary, check if all libGL.so are linked to the nvidia libary:

Code: Select all

 find /usr -iname "*libGL.so*" -exec ls -l {} \; 
For me the libGL.so.1.2.0 was not linked so I needed to to:

Code: Select all

mv /usr/lib/libGL.so.1.2.0 /usr/lib/oldlibGL.so.1.2.0
ln -s /usr/lib/nvidia/libGL.so /usr/lib/libGL.so.1.2.0
mv /usr/lib64/libGL.so.1.2.0 /usr/lib64/oldlibGL.so.1.2.0
ln -s /usr/lib64/nvidia/libGL.so /usr/lib64/libGL.so.1.2.0
find /usr -iname "*libGL.so*" -exec ls -l {} \;
The missing link caused the problem:

Code: Select all

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Hope this helps :) - These commands need to be runned as root, but I guess you knew this.

dcapocelli
Posts: 1
Joined: 2017/02/15 17:34:45

Re: Indirect GLX rendering CentOS 7.2

Post by dcapocelli » 2017/02/15 17:36:29

changing the Xorg binary with a script gives me blank screen when i restart X.
What am i doing wrong?
BR,
D.

Post Reply

Return to “CentOS 7 - General Support”