MATE Desktop issue

General support questions
Mvoinescu
Posts: 4
Joined: 2017/09/02 11:20:31

MATE Desktop issue

Postby Mvoinescu » 2017/09/02 11:27:32

Hi there.
I have been trying to install the MATE Desktop for 2 days and I cannot do it for the life of me.

At first I thought I have forgot some updates, or that they have no happened but everything is up to date.
I'm using Centos 7 and each time I run yum groupinstall -y "MATE Desktop" it fails telling me that I need glib version 2.50.3 or higher.

I tried updating the gblib but it still remains at 2.46

Any ideas?

User avatar
TrevorH
Forum Moderator
Posts: 20966
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: MATE Desktop issue

Postby TrevorH » 2017/09/02 11:33:19

How are you doing the install? yum group install "MATE Desktop" should be the method once you have installed and enabled the EPEL repo. Post the output from rpm -q glib2 centos-release
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Mvoinescu
Posts: 4
Joined: 2017/09/02 11:20:31

Re: MATE Desktop issue

Postby Mvoinescu » 2017/09/02 11:52:59

the output comes as
glib2-2.45.2-4.e17.x86_64
centos-release-7-3.1611.e17.centos.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 20966
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: MATE Desktop issue

Postby TrevorH » 2017/09/02 12:14:28

OK. So the issue is that EPEL have rebuilt the MATE packages against RHEL 7.4 (which is what they follow, they don't build for CentOS per se, it just happens to work as CentOS is a clone of RHEL). As CentOS 7.4 is not GA yet - it's waiting for the isos to be built - you're running into package differences from 7.3 to 7.4 where glib2 was rebased from 2.46 to 2.50.

You can get CentOS to the 7.4 level by enabling the CR repo and updating from there first. Use yum --enablerepo=cr update to update your system to what will be 7.4 once the isos have been built. That should get your system to the required level to be able to install the updated MATE packages. You may also need to enable the CR repo when doing the group install "MATE Desktop" - same switch to yum - it's a one-time override so needs to be done on every yum command where you want to use it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Mvoinescu
Posts: 4
Joined: 2017/09/02 11:20:31

Re: MATE Desktop issue

Postby Mvoinescu » 2017/09/02 12:44:49

Aha I understand, right now CentOS is doing the update to the new version and I saw it was installing the glib 2.50 version.

As for that CR repo command, might I ask the command for that as well please? Sorry I'm kinda new to this :D learning using the LFCS tutorial on pluralsight

User avatar
TrevorH
Forum Moderator
Posts: 20966
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: MATE Desktop issue

Postby TrevorH » 2017/09/02 12:54:22

It just means you need to use yum --enablerepo=cr ... wherever you would normally use yum ... as that tells yum to enable the CR repo for this one command only. You could edit /etc/yum.repos.d/CentOS-CR.repo and permanently enable it if you wanted or use yum-config-manager to enable it instead but I think it's better to leave it disabled and enable it on demand.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Mvoinescu
Posts: 4
Joined: 2017/09/02 11:20:31

Re: MATE Desktop issue

Postby Mvoinescu » 2017/09/02 13:01:23

You are a lifesaver. Thank you very much. I have been banging my head on a wall for 2 days trying to figure it out. Tried every possible thing, except the easiest and the best one. Register on the forum and ask the correct people :D

I thought that maybe the download was corrupt or something so I think I reinstalled the OS like 5-8 times

stevesdl
Posts: 5
Joined: 2017/09/05 17:11:15

Re: MATE Desktop issue

Postby stevesdl » 2017/09/05 19:45:57

Excellent answer TrevorH!
I too ran into the same issue with CentOS 7.3. Your solution worked.
There were a lot of files to be update for this so advise if this was the correct syntax please.

yum --enablerepo=cr update groupinstall -y “MATE Desktop”

Thank you
Steve