cannot run yum update due to broken and conflicting packages

General support questions
kayb
Posts: 2
Joined: 2017/09/14 15:44:00

cannot run yum update due to broken and conflicting packages

Postby kayb » 2017/09/14 16:02:29

a yum update command never completes, it always ends with the following error which i do not know how to resolve:

--> Finished Dependency Resolution
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
Requires: libimobiledevice.so.4()(64bit)
Removing: libimobiledevice-1.1.5-6.el7.x86_64 (@base/$releasever)
libimobiledevice.so.4()(64bit)
Updated By: libimobiledevice-1.2.0-1.el7.x86_64 (base)
~libimobiledevice.so.6()(64bit)
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
Requires: libplist.so.1()(64bit)
Removing: libplist-1.10-4.el7.x86_64 (@base/$releasever)
libplist.so.1()(64bit)
Updated By: libplist-1.12-3.el7.x86_64 (base)
~libplist.so.3()(64bit)
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
Requires: libusbmuxd.so.2()(64bit)
Removing: usbmuxd-1.0.8-11.el7.x86_64 (@base/$releasever)
libusbmuxd.so.2()(64bit)
Obsoleted By: usbmuxd-1.1.0-1.el7.x86_64 (base)
Not found
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-common-4.5.0-21.el7.centos.1.2.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.5.0-21.el7.centos.1.2.noarch

my uname -a command output is : Linux localhost.localdomain 3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 4 15:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
my cat /etc/centos-release command output is : CentOS Linux release 7.3.1611 (Core)

I will appreciate any help on this issue.

User avatar
TrevorH
Forum Moderator
Posts: 20308
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: cannot run yum update due to broken and conflicting packages

Postby TrevorH » 2017/09/14 16:04:29

CentOS 7.4 was released yesterday and this is one of the known issues documented in the release notes which you can find on https://wiki.centos.org/Manuals/ReleaseNotes/CentOS7
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kayb
Posts: 2
Joined: 2017/09/14 15:44:00

Re: cannot run yum update due to broken and conflicting packages

Postby kayb » 2017/09/14 17:15:23

TrevorH wrote:CentOS 7.4 was released yesterday and this is one of the known issues documented in the release notes which you can find on https://wiki.centos.org/Manuals/ReleaseNotes/CentOS7


Thank you so much. I am now updating/upgrading my PC. Many thanks once again.

geotex
Posts: 1
Joined: 2017/09/14 19:29:15

Re: cannot run yum update due to broken and conflicting packages

Postby geotex » 2017/09/14 20:03:20

Thank you for the concise help. Now looking at an update of hundreds of items, that says "Complete!"


Return to “CentOS 7 - General Support”

Who is online

Users browsing this forum: No registered users and 9 guests