[7.4] Samba netbios aliases issues.

General support questions
groblus
Posts: 1
Joined: 2017/09/19 16:04:38

[7.4] Samba netbios aliases issues.

Postby groblus » 2017/09/19 16:14:15

Hi everyone,
I'm using fresh and clean CentOS 7.4 and I'm trying to get samba aliases to work. I have a minimal smb.conf:

Code: Select all

[global]
    netbios aliases = PR RC
    smb ports = 139
    include = /etc/samba/smb-%L.conf

But as a result of testparm I get:

Code: Select all

Can't find include file /etc/samba/smb-TS.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
    netbios aliases = PR RC
    smb ports = 139
    idmap config * : backend = tdb
    include = /etc/samba/smb-TS.conf

It occurs that %L get substituted only to the hostname (TS is machines hostname), but not to netbios aliases.
I based my conf on that decription: https://www.samba.org/samba/docs/man/Sa ... marts.html
I also found some topics concerning include not working properly!? (viewtopic.php?t=27914)
But even when I include my files "by hand" in my smb.conf I get some poor results, because both aliases PR and RC share the same folder visible.
Here is testparm on "hand incliuded" confs

Code: Select all

[global]
   netbios aliases = PR RC
   netbios name = RC
   workgroup = FRA
   server max protocol = NT1
   smb ports = 139
   idmap config * : backend = tdb
   include = /etc/samba/smb-PR.conf
   guest ok = Yes


[PR]
   comment = Test 1
   path = /data/PR
   include = /etc/samba/smb-RC.conf


[RC]
   comment = Test 2
   path = /data/RenderfarmConf


Any clues on that?

Regards