Unreliable & unexpected bahaviour

General support questions
hajes
Posts: 1
Joined: 2017/09/20 16:00:47

Unreliable & unexpected bahaviour

Postby hajes » 2017/09/20 16:12:57

Hi,

I did custom build a file server with SuperMicro MoBo. If details are important, I can past all later...on request.

I spent long years on Debian but SuperMicro doesn't officially support Debian...so I tried CentOS 7 since I used to play with RedHat long time ago. And an idea of official support appealed to me.

While it is Linux system, it is different from Debian and I have no idea about many things. Most likely it has been screwed up by myself.

When I finally got all running...came Windows-like behaviour....first stopped to work HTTPD, then NFS that worked. Reinstalled HTTPD and shortly after it doesn't work again and now SMB fails too.

There is no errors in logs (at least not red/critical ones nor what I'm able to interpret)

The only way to get it running again is

Code: Select all

yum remove && yum install
but as of now second reboot later...vicious circle didn't stop. Two days ago I removed HTTPD...it doesn't work again.

iptables works weird as well...for example whenever I specify an IP address or range...iptables ignores without error and happily blocks requests.

SElinux is in permissive mode

====

UPDATE - further details

installed as Minimal installation and all packages were installed from local repo. Usually, downloaded first from another computer. There is possibility I something screwed up but yum doesn't complain so I assumed all is ok.

In beginning I noticed weird behaviour of intermittent server response. I use "mc"...sometimes it starts in fraction of second and next time it waits, freezes for a minute before it starts.

Another weird behaviour is SSH/SFTP...I sometimes uploaded/downloaded files from my Apple and it was quick about 60-80MBs. Then I moved a 7kB file and it got stuck for no reasons. Firewall was off. I had to kill Apple muCommander (Java old school Norton Commander style) and try again. It works/un-work randomly but it may be caused more by Apple/muCommander side than CentOS SSH server.

In the beginning I didn't play too much with NFS, SMB and HTTP...I needed to get running RAID 10 archive and sort out about 5TB of data. But I wanted some sort of monitoring so I see server performance. I installed MRTG...then Cacti, removed Cacti because it is complicated and ended up with Munin. All works now and then HTTP server unable to start...no errors in logs...removed and installed again. It worked for a day...NFS stopped to work...I started to use slow Samba...Apple somehow doesn't like Samba.None works now :-D

Samba runs 60-80MBs max over GigaLAN...often just 35MBs...it was reason why I moved away from commercial NAS solutions from Synology...it was even worst and bloody slow.

NFS is great and quick...I saw 100+MBs over GigaLAN...despite manual claims NFS4 doesn't need portmap anymore...Apple is unable to connect without portmap but it may be just misconfiguration on my side.


I wonder what is going on...is CentOS self-f*king as Windows or do I have something wrong, please?