Comodo WAF

General support questions
Bossmanuk
Posts: 2
Joined: 2017/11/19 14:38:09

Comodo WAF

Postby Bossmanuk » 2017/11/19 14:45:29

Hi Everyone,
I am trying to install Comodo WAF on my server which has installed successfully but when i try to restart my apache server i am getting the following error below

Code: Select all

Nov 19 14:42:18 hostname systemd[1]: Starting The Apache HTTP Server...
Nov 19 14:42:18 hostname httpd[4557]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 32 of /etc/httpd/conf.d/zzzz_cwaf_security2.conf: Could not open configuration file /usr/local/cwaf/etc/cwaf.conf: Permission denied
Nov 19 14:42:18 hostname systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Nov 19 14:42:18 hostname kill[4559]: kill: cannot find process ""
Nov 19 14:42:18 hostname systemd[1]: httpd.service: control process exited, code=exited status=1
Nov 19 14:42:18 hostname systemd[1]: Failed to start The Apache HTTP Server.
Nov 19 14:42:18 hostname systemd[1]: Unit httpd.service entered failed state.
Nov 19 14:42:18 hostname systemd[1]: httpd.service failed.


Is this a permission issue with SELinux or something else?

Thanks

Bossmanuk
Last edited by Bossmanuk on 2017/11/19 20:00:32, edited 1 time in total.

lightman47
Posts: 536
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Comodo WAF

Postby lightman47 » 2017/11/19 16:30:32

Did Apache run correctly before the CWAF install? I ask because I got the "httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf" error on mine (no CWAF) when I attempted to import an old httpd.conf file into a new apache installation to save myself having to edit. I had to re-install apache and manually edit the new file after all.

Hope this is helpful.
:)

Bossmanuk
Posts: 2
Joined: 2017/11/19 14:38:09

Re: Comodo WAF

Postby Bossmanuk » 2017/11/19 18:14:46

Hi lightman47,
Yeah it was running perfectly fine before, i wanted to install the comodo waf rules and app into my CentOS but now i am getting this permission issue and can't work out what it is :?