/etc/issue prompting as text while login to server via putty

General support questions
nokiacephusers
Posts: 4
Joined: 2017/09/15 12:02:31

/etc/issue prompting as text while login to server via putty

Postby nokiacephusers » 2017/11/22 10:50:52

Hello,

We did a yum update from 7.2 to 7.4 after that we are facing some issues in the login prompt.

Attaching the screenshot, as it shows the problem very clearly.

Please check the attachment and let us know what data you would require for further troubleshoot.

Thanks



# cat /etc/issue
\S
Kernel \r on an \m


# cat /etc/issue.net
\S
Kernel \r on an \m
Attachments
non-working putty.PNG
non-working putty.PNG (22.71 KiB) Viewed 127 times
working-putty.PNG
working-putty.PNG (29.91 KiB) Viewed 127 times

pjsr2
Posts: 203
Joined: 2014/03/27 20:11:07

Re: /etc/issue prompting as text while login to server via putty

Postby pjsr2 » 2017/11/22 17:09:13

Look at the /etc/ssh/sshd_config file and check the value of "Banner".
To disable it, change that line to:

Code: Select all

#Banner none

nokiacephusers
Posts: 4
Joined: 2017/09/15 12:02:31

Re: /etc/issue prompting as text while login to server via putty

Postby nokiacephusers » 2017/11/23 05:07:46

Many thanks for the update.

Previously we add banner entry like.
#vim /etc/ssh/sshd_config
Banner /etc/issue

#cat /etc/issue
No authorised access

After 7.2 to 7.4 update, as it changed to
# cat /etc/issue
\S
Kernel \r on an \m

My question, does any rpm cause overwrite and set to default ?

Thanks

pjsr2
Posts: 203
Joined: 2014/03/27 20:11:07

Re: /etc/issue prompting as text while login to server via putty

Postby pjsr2 » 2017/11/23 08:48:16

In CentOS 7.4 /etc/ssh/sshd_config is changed. On my systems I never changed contents of /etc/ssh/sshd_config, so I cannot tell you how customization of this file is handled during the update.

#cat /etc/issue
No authorised access

Are you sure that is the literal error message? Or are you getting: "cat: /etc/issue: Permission denied"
/etc/issue is owned by user root and group root. It has read+write permissions for root and read-only for group and other. As far as I can tell this is the default in CentOS 6.x and 7.x.

The Banner option is only available for ssh protocol version 2. In CentOS 7.4, support for protocol version 1 has been removed from sshd. Could it be that your putty client has a preference for version 1 and only uses version 2 when communicating with your 7.4 box?