No desktop after updates

General support questions
kingmouf
Posts: 7
Joined: 2015/11/24 14:29:21

No desktop after updates

Post by kingmouf » 2018/01/09 11:58:23

Dear all,

I need your help. I have a desktop PC with CentOS 7. I was trying to make the recent updates.

sudo yum update stumbled multiple times to the gstreamer packages, so in order to proceed I used yum remove gstreamer to remove the package and then try to complete the updates and clean install gstreamer again. However during the remove process, it crashed/failed and as a result, since then I cannot have desktop again.

Through command line I managed to update everything, but I cannot do anything about the desktop.

Any help would be highly appreciated.

Thanx,
Andreas

hunter86_bg
Posts: 1321
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: No desktop after updates

Post by hunter86_bg » 2018/01/09 12:44:16

First you can see details regarding the broken transaction via:

Code: Select all

yum history
yum history info ID
Where the id is taken from the first command.
Then manually remove any duplicate package (the newer version), and redo the same transaction via:

Code: Select all

yum history redo ID

User avatar
TrevorH
Forum Moderator
Posts: 23471
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No desktop after updates

Post by TrevorH » 2018/01/09 12:45:06

However during the remove process, it crashed/failed and as a result, since then I cannot have desktop again.
How? Error messages?
I cannot do anything about the desktop.
Symptoms? Error messages? Log entries? Installed proprietary video drivers previously?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kingmouf
Posts: 7
Joined: 2015/11/24 14:29:21

Re: No desktop after updates

Post by kingmouf » 2018/01/09 13:01:03

TrevorH wrote:
However during the remove process, it crashed/failed and as a result, since then I cannot have desktop again.
How? Error messages?
I was working on the desktop with an open terminal window and that was the last graphical thing I ever saw.
TrevorH wrote:
I cannot do anything about the desktop.
Symptoms? Error messages? Log entries? Installed proprietary video drivers previously?
I have an nVidia GTX980 card that I use for CUDA development. So yes, there were nvidia drivers. I use the negativo17 process for all nvidia/CUDA related. I since tried to reinstall everything and it is supposedly done. No desktop though.

When I reboot, it takes me to a console login screen. Once I put my credentials and login, if I write runlevel, I get back N 5, which I guess should mean that I would have graphical interface. The default target for systemdctl says it is graphics.target and if I use the command systemctl isolate graphics.target nothing happens. If I try "startx", then I get some messages and :

The XKEYBOARD keymap compiler (xkbcomp) reports:
Warning: symbol map for key <KPDL> redefined.
Using last definition for conflicting fields.
Errors from xkbcomp are not fatal to the X server
xinit: connection to X server lost
waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.
I am not really experienced, so maybe I am not providing the proper info to you. If you guide me to exactly what you want to check, I'll try to provide all info.

Thank you!
Andreas

User avatar
TrevorH
Forum Moderator
Posts: 23471
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No desktop after updates

Post by TrevorH » 2018/01/09 13:32:28

Sounds like your video drivers are the problem. What's in /var/log/Xorg.0.log ?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kingmouf
Posts: 7
Joined: 2015/11/24 14:29:21

Re: No desktop after updates

Post by kingmouf » 2018/01/09 13:35:40

TrevorH wrote:Sounds like your video drivers are the problem. What's in /var/log/Xorg.0.log ?
Long message ahead:

Code: Select all

cat /var/log/Xorg.0.log

[   770.336] 
X.Org X Server 1.19.3
Release Date: 2017-03-15
[   770.336] X Protocol Version 11, Revision 0
[   770.337] Build Operating System:  3.10.0-514.16.1.el7.x86_64 
[   770.337] Current Operating System: Linux idefix 3.10.0-693.11.6.el7.x86_64 #1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64
[   770.337] Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-693.11.6.el7.x86_64 root=/dev/mapper/idefix-root ro crashkernel=auto rd.lvm.lv=idefix/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=idefix/root vconsole.keymap=us rhgb video=vesa:off LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau
[   770.338] Build Date: 05 August 2017  06:19:43AM
[   770.338] Build ID: xorg-x11-server 1.19.3-11.el7 
[   770.339] Current version of pixman: 0.34.0
[   770.339]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   770.339] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   770.341] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan  9 14:59:15 2018
[   770.342] (==) Using config file: "/etc/X11/xorg.conf"
[   770.342] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   770.342] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   770.343] (==) ServerLayout "Default Layout"
[   770.343] (**) |-->Screen "Default Screen" (0)
[   770.343] (**) |   |-->Monitor "<default monitor>"
[   770.343] (**) |   |-->Device "Device0"
[   770.343] (==) No monitor specified for screen "Default Screen".
        Using a default monitor configuration.
[   770.343] (**) |-->Input Device "Keyboard0"
[   770.343] (**) |-->Input Device "Mouse0"
[   770.343] (==) Automatically adding devices
[   770.343] (==) Automatically enabling devices
[   770.343] (==) Automatically adding GPU devices
[   770.343] (==) Automatically binding GPU devices
[   770.343] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   770.343] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d,
        built-ins
[   770.343] (**) ModulePath set to "/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[   770.343] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   770.343] (WW) Disabling Keyboard0
[   770.343] (WW) Disabling Mouse0
[   770.343] (II) Loader magic: 0x5645a8219020
[   770.343] (II) Module ABI versions:
[   770.343]    X.Org ANSI C Emulation: 0.4
[   770.343]    X.Org Video Driver: 23.0
[   770.343]    X.Org XInput driver : 24.1
[   770.343]    X.Org Server Extension : 10.0
[   770.343] (II) xfree86: Adding drm device (/dev/dri/card0)
[   770.345] (--) PCI:*(0:1:0:0) 10de:13c0:1043:8518 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   770.345] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[   770.345] (II) "glx" will be loaded by default.
[   770.345] (II) LoadModule: "glx"
[   770.345] (II) Loading /usr/lib64/nvidia/xorg/libglx.so
[   770.351] (II) Module glx: vendor="NVIDIA Corporation"
[   770.351]    compiled for 4.0.2, module version = 1.0.0
[   770.351]    Module class: X.Org Server Extension
[   770.351] (II) NVIDIA GLX Module  384.98  Thu Oct 26 14:35:55 PDT 2017
[   770.351] (II) LoadModule: "nvidia"
[   770.351] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   770.352] (II) Module nvidia: vendor="NVIDIA Corporation"
[   770.352]    compiled for 4.0.2, module version = 1.0.0
[   770.352]    Module class: X.Org Video Driver
[   770.352] (II) NVIDIA dlloader X Driver  384.98  Thu Oct 26 14:06:45 PDT 2017
[   770.352] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   770.352] (++) using VT number 1

[   770.355] (II) Loading sub module "fb"
[   770.355] (II) LoadModule: "fb"
[   770.355] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   770.355] (II) Module fb: vendor="X.Org Foundation"
[   770.355]    compiled for 1.19.3, module version = 1.0.0
[   770.355]    ABI class: X.Org ANSI C Emulation, version 0.4
[   770.355] (II) Loading sub module "wfb"
[   770.355] (II) LoadModule: "wfb"
[   770.355] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   770.355] (II) Module wfb: vendor="X.Org Foundation"
[   770.355]    compiled for 1.19.3, module version = 1.0.0
[   770.355]    ABI class: X.Org ANSI C Emulation, version 0.4
[   770.355] (II) Loading sub module "ramdac"
[   770.355] (II) LoadModule: "ramdac"
[   770.355] (II) Module "ramdac" already built-in
[   770.356] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   770.356] (==) NVIDIA(0): RGB weight 888
[   770.356] (==) NVIDIA(0): Default visual is TrueColor
[   770.356] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   770.356] (**) NVIDIA(0): Option "DPI" "96 x 96"
[   770.356] (**) NVIDIA(0): Enabling 2D acceleration
[   770.851] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   770.851] (--) NVIDIA(0):     CRT-0 (boot)
[   770.851] (--) NVIDIA(0):     DFP-0
[   770.851] (--) NVIDIA(0):     DFP-1
[   770.851] (--) NVIDIA(0):     DFP-2
[   770.851] (--) NVIDIA(0):     DFP-3
[   770.851] (--) NVIDIA(0):     DFP-4
[   770.851] (--) NVIDIA(0):     DFP-5
[   770.851] (--) NVIDIA(0):     DFP-6
[   770.851] (--) NVIDIA(0):     DFP-7
[   770.852] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 980 (GM204-A) at PCI:1:0:0 (GPU-0)
[   770.852] (--) NVIDIA(0): Memory: 4194304 kBytes
[   770.852] (--) NVIDIA(0): VideoBIOS: 84.04.31.00.dd
[   770.852] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   770.895] (--) NVIDIA(GPU-0): Philips 221E (CRT-0): connected
[   770.895] (--) NVIDIA(GPU-0): Philips 221E (CRT-0): 400.0 MHz maximum pixel clock
[   770.895] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-0: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[   770.913] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   770.913] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-2: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
[   770.913] (--) NVIDIA(GPU-0): DFP-2: 960.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-3: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
[   770.913] (--) NVIDIA(GPU-0): DFP-3: 165.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-4: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[   770.913] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-5: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-5: Internal TMDS
[   770.913] (--) NVIDIA(GPU-0): DFP-5: 165.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-6: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-6: Internal DisplayPort
[   770.913] (--) NVIDIA(GPU-0): DFP-6: 960.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.913] (--) NVIDIA(GPU-0): DFP-7: disconnected
[   770.913] (--) NVIDIA(GPU-0): DFP-7: Internal TMDS
[   770.913] (--) NVIDIA(GPU-0): DFP-7: 165.0 MHz maximum pixel clock
[   770.913] (--) NVIDIA(GPU-0): 
[   770.915] (II) NVIDIA(0): Validated MetaModes:
[   770.915] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select"
[   770.915] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[   770.920] (**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X config option
[   770.920] (--) Depth 24 pixmap format is 32 bpp
[   770.920] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[   770.920] (II) NVIDIA:     access.
[   770.923] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   770.923] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   770.923] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   770.923] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   770.923] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   770.924] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   770.924] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   770.924] (II) NVIDIA(0):     Config Options in the README.
[   770.936] (II) NVIDIA(0): Setting mode "CRT-0:nvidia-auto-select"
[   770.984] (==) NVIDIA(0): Disabling shared memory pixmaps
[   770.984] (==) NVIDIA(0): Backing store enabled
[   770.984] (==) NVIDIA(0): Silken mouse enabled
[   770.984] (==) NVIDIA(0): DPMS enabled
[   770.984] (WW) NVIDIA(0): Option "NoLogo" is not used
[   770.984] (II) Loading sub module "dri2"
[   770.984] (II) LoadModule: "dri2"
[   770.984] (II) Module "dri2" already built-in
[   770.984] (II) NVIDIA(0): [DRI2] Setup complete
[   770.984] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   770.984] (--) RandR disabled
[   770.987] (II) SELinux: Disabled by boolean
[   770.987] (II) Initializing extension GLX
[   771.013] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   771.013] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   771.013] (**) Power Button: Applying InputClass "system-keyboard"
[   771.013] (II) LoadModule: "evdev"
[   771.013] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[   771.013] (II) Module evdev: vendor="X.Org Foundation"
[   771.013]    compiled for 1.19.3, module version = 2.10.5
[   771.013]    Module class: X.Org XInput Driver
[   771.013]    ABI class: X.Org XInput driver, version 24.1
[   771.013] (II) Using input driver 'evdev' for 'Power Button'
[   771.013] (**) Power Button: always reports core events
[   771.013] (**) evdev: Power Button: Device: "/dev/input/event1"
[   771.013] (--) evdev: Power Button: Vendor 0 Product 0x1
[   771.013] (--) evdev: Power Button: Found keys
[   771.013] (II) evdev: Power Button: Configuring as keyboard
[   771.013] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[   771.013] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   771.013] (**) Option "xkb_rules" "evdev"
[   771.013] (**) Option "xkb_layout" "us,gr"
[   771.013] (**) Option "xkb_variant" ","
[   771.013] (**) Option "xkb_options" "grp:lalt_lshift_toggle"
[   771.028] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[   771.028] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   771.028] (**) Power Button: Applying InputClass "system-keyboard"
[   771.028] (II) Using input driver 'evdev' for 'Power Button'
[   771.028] (**) Power Button: always reports core events
[   771.028] (**) evdev: Power Button: Device: "/dev/input/event0"
[   771.028] (--) evdev: Power Button: Vendor 0 Product 0x1
[   771.028] (--) evdev: Power Button: Found keys
[   771.028] (II) evdev: Power Button: Configuring as keyboard
[   771.028] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[   771.028] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[   771.028] (**) Option "xkb_rules" "evdev"
[   771.028] (**) Option "xkb_layout" "us,gr"
[   771.028] (**) Option "xkb_variant" ","
[   771.028] (**) Option "xkb_options" "grp:lalt_lshift_toggle"
[   771.028] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event11)
[   771.028] (II) No input driver specified, ignoring this device.
[   771.028] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event12)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event13)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event14)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event10)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event6)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.029] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event7)
[   771.029] (II) No input driver specified, ignoring this device.
[   771.029] (II) This device may have been added with another device file.
[   771.030] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event8)
[   771.030] (II) No input driver specified, ignoring this device.
[   771.030] (II) This device may have been added with another device file.
[   771.030] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event9)
[   771.030] (II) No input driver specified, ignoring this device.
[   771.030] (II) This device may have been added with another device file.
[   771.030] (II) config/udev: Adding input device PixArt USB Optical Mouse (/dev/input/event2)
[   771.030] (**) PixArt USB Optical Mouse: Applying InputClass "evdev pointer catchall"
[   771.030] (II) Using input driver 'evdev' for 'PixArt USB Optical Mouse'
[   771.030] (**) PixArt USB Optical Mouse: always reports core events
[   771.030] (**) evdev: PixArt USB Optical Mouse: Device: "/dev/input/event2"
[   771.081] (--) evdev: PixArt USB Optical Mouse: Vendor 0x461 Product 0x4e22
[   771.081] (--) evdev: PixArt USB Optical Mouse: Found 12 mouse buttons
[   771.081] (--) evdev: PixArt USB Optical Mouse: Found scroll wheel(s)
[   771.081] (--) evdev: PixArt USB Optical Mouse: Found relative axes
[   771.081] (--) evdev: PixArt USB Optical Mouse: Found x and y relative axes
[   771.081] (II) evdev: PixArt USB Optical Mouse: Configuring as mouse
[   771.081] (II) evdev: PixArt USB Optical Mouse: Adding scrollwheel support
[   771.081] (**) evdev: PixArt USB Optical Mouse: YAxisMapping: buttons 4 and 5
[   771.081] (**) evdev: PixArt USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   771.081] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.7/2-1.7:1.0/input/input27/event2"
[   771.081] (II) XINPUT: Adding extended input device "PixArt USB Optical Mouse" (type: MOUSE, id 8)
[   771.081] (II) evdev: PixArt USB Optical Mouse: initialized for relative axes.
[   771.081] (**) PixArt USB Optical Mouse: (accel) keeping acceleration scheme 1
[   771.081] (**) PixArt USB Optical Mouse: (accel) acceleration profile 0
[   771.081] (**) PixArt USB Optical Mouse: (accel) acceleration factor: 2.000
[   771.081] (**) PixArt USB Optical Mouse: (accel) acceleration threshold: 4
[   771.081] (II) config/udev: Adding input device PixArt USB Optical Mouse (/dev/input/mouse0)
[   771.081] (II) No input driver specified, ignoring this device.
[   771.081] (II) This device may have been added with another device file.
[   771.082] (II) config/udev: Adding input device DELL Dell USB Entry Keyboard (/dev/input/event3)
[   771.082] (**) DELL Dell USB Entry Keyboard: Applying InputClass "evdev keyboard catchall"
[   771.082] (**) DELL Dell USB Entry Keyboard: Applying InputClass "system-keyboard"
[   771.082] (II) Using input driver 'evdev' for 'DELL Dell USB Entry Keyboard'
[   771.082] (**) DELL Dell USB Entry Keyboard: always reports core events
[   771.082] (**) evdev: DELL Dell USB Entry Keyboard: Device: "/dev/input/event3"
[   771.082] (--) evdev: DELL Dell USB Entry Keyboard: Vendor 0x413c Product 0x2107
[   771.082] (--) evdev: DELL Dell USB Entry Keyboard: Found keys
[   771.082] (II) evdev: DELL Dell USB Entry Keyboard: Configuring as keyboard
[   771.082] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8:1.0/input/input3/event3"
[   771.082] (II) XINPUT: Adding extended input device "DELL Dell USB Entry Keyboard" (type: KEYBOARD, id 9)
[   771.082] (**) Option "xkb_rules" "evdev"
[   771.082] (**) Option "xkb_layout" "us,gr"
[   771.082] (**) Option "xkb_variant" ","
[   771.082] (**) Option "xkb_options" "grp:lalt_lshift_toggle"
[   771.082] (II) config/udev: Adding input device Eee PC WMI hotkeys (/dev/input/event5)
[   771.082] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[   771.082] (**) Eee PC WMI hotkeys: Applying InputClass "system-keyboard"
[   771.082] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[   771.082] (**) Eee PC WMI hotkeys: always reports core events
[   771.083] (**) evdev: Eee PC WMI hotkeys: Device: "/dev/input/event5"
[   771.083] (--) evdev: Eee PC WMI hotkeys: Vendor 0 Product 0
[   771.083] (--) evdev: Eee PC WMI hotkeys: Found keys
[   771.083] (II) evdev: Eee PC WMI hotkeys: Configuring as keyboard
[   771.083] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input5/event5"
[   771.083] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD, id 10)
[   771.083] (**) Option "xkb_rules" "evdev"
[   771.083] (**) Option "xkb_layout" "us,gr"
[   771.083] (**) Option "xkb_variant" ","
[   771.083] (**) Option "xkb_options" "grp:lalt_lshift_toggle"
[   771.083] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[   771.083] (II) No input driver specified, ignoring this device.
[   771.083] (II) This device may have been added with another device file.
[   771.297] (II) evdev: Eee PC WMI hotkeys: Close
[   771.297] (II) UnloadModule: "evdev"
[   771.297] (II) evdev: DELL Dell USB Entry Keyboard: Close
[   771.297] (II) UnloadModule: "evdev"
[   771.297] (II) evdev: PixArt USB Optical Mouse: Close
[   771.298] (II) UnloadModule: "evdev"
[   771.298] (II) evdev: Power Button: Close
[   771.298] (II) UnloadModule: "evdev"
[   771.298] (II) evdev: Power Button: Close
[   771.298] (II) UnloadModule: "evdev"
[   771.810] (II) NVIDIA(GPU-0): Deleting GPU-0
[   771.811] (II) Server terminated successfully (0). Closing log file.

kingmouf
Posts: 7
Joined: 2015/11/24 14:29:21

Re: No desktop after updates

Post by kingmouf » 2018/01/09 13:39:13

I should note that I am able to execute CUDA and OpenCL tests.

hmg22
Posts: 22
Joined: 2012/10/25 08:40:52

Re: No desktop after updates

Post by hmg22 » 2018/01/11 10:12:28

BS"D

It seems your yum update managed to update the kernel. If so, you need to recompile your Nvidia driver against the new kernel (use the .run file to uninstall, then re-install).

HMG

kingmouf
Posts: 7
Joined: 2015/11/24 14:29:21

Re: No desktop after updates

Post by kingmouf » 2018/01/11 11:34:39

Hi all,

thank you for all your replies. So I followed hmg22 instructions to install the drivers again. This didnt resolve the issue. However, I noticed that when gstreamer packages were removed also certain packages related to gnome were also removed. I tried to reinstall everything gnome related and alas it worked.

Now everything seems to be back to normal.

Again thank you all for your time and insights.

Best,
Andreas

bonedome
Posts: 44
Joined: 2017/04/22 08:11:04

Re: No desktop after updates

Post by bonedome » 2018/01/11 22:56:23

Hello
just to add to this post, if you try to remove a package with yum and it tries to pull/erase a load of other stuff you wish to keep, I use
(as root)

Code: Select all

rpm -e --nodeps name-of-package

Post Reply