Help resolve packet dependency

General support questions
Post Reply
ricardo.claus
Posts: 49
Joined: 2016/07/04 12:46:08

Help resolve packet dependency

Post by ricardo.claus » 2018/01/16 17:34:48

Hello everyone,
I'm looking for help solving some package dependencies.
I'm trying to install a rpm.rum package, in a CentOS Linux release 7.4.1708 (Core) minimal version.

I get these dependency errors:

libc.so.6 is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.0) is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.1) is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.1.2) is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.2) is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.2.3) is required by bitdefender-scanner-7.6-4.i586
        libc.so.6 (GLIBC_2.3) is required by bitdefender-scanner-7.6-4.i586
        libdl.so.2 is required by bitdefender-scanner-7.6-4.i586
        libdl.so.2 (GLIBC_2.0) is required by bitdefender-scanner-7.6-4.i586
        libdl.so.2 (GLIBC_2.1) is required by bitdefender-scanner-7.6-4.i586
        libpthread.so.0 is required by bitdefender-scanner-7.6-4.i586
        libpthread.so.0 (GLIBC_2.0) is required by bitdefender-scanner-7.6-4.i586
        libpthread.so.0 (GLIBC_2.1) is required by bitdefender-scanner-7.6-4.i586
        libpthread.so.0 (GLIBC_2.2) is required by bitdefender-scanner-7.6-4.i586
        libstdc ++. so.5 is required by bitdefender-scanner-7.6-4.i586

With the find command, I found these libraries in:
/usr/lib64/libpthread.so.0
/usr/lib64/libdl.so.2
/usr/lib64/libc.so.6

# yum provides libc.so.6
glibc-2.17-196.el7.i686: The GNU libc libraries
Repo: base
Result from:
Provides: libc.so.6

glibc-2.17-196.el7_4.2.i686: The GNU libc libraries
Repo: updates
Result from:
Provides: libc.so.6

As I understand it, dependencies refer to the glibc package. But I have it installed.
# rpm -qa | grep glibc
glibc-devel-2.17-196.el7_4.2.x86_64
glibc-utils-2.17-196.el7_4.2.x86_64
glibc-common-2.17-196.el7_4.2.x86_64
glibc-static-2.17-196.el7_4.2.x86_64
glibc-2.17-196.el7_4.2.x86_64
glibc-headers-2.17-196.el7_4.2.x86_64

Could someone help me solve these dependencies?
Thank you!

User avatar
avij
Forum Moderator
Posts: 2679
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Help resolve packet dependency

Post by avij » 2018/01/16 17:48:22

The package you are trying to install is 32bit whereas your CentOS is 64bit. In addition, it seems to be packaged for an older version of CentOS.

You may still be able to install it on CentOS 7, but whether it will actually work as intended is a different matter.

How did you try to install the package? By using rpm? Try yum install ./bitdefender-scanner-7.6-4.i586.rpm which, if you are lucky, may be able to find and install all the required dependencies.

ricardo.claus
Posts: 49
Joined: 2016/07/04 12:46:08

Re: Help resolve packet dependency

Post by ricardo.claus » 2018/01/16 18:13:49

Dear Avij
Thanks for the initial contact.

I'm trying to install the package this way:

# sh BitDefender-Antivirus-Scanner-nogui-7.6-4.linux-gcc3x.i586.rpm.run

I tried this way, but it did not work:
# yum install ./BitDefender-Antivirus-Scanner-nogui-7.6-4.linux-gcc3x.i586.rpm.run
No package ./BitDefender-Antivirus-Scanner-nogui-7.6-4.linux-gcc3x.i586.rpm.run available.

Strange is that I have this package installed in a testing VM.
The version of this VM that ran the install is this:

# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)
# uname -a
Linux test.domain.local 3.10.0-693.2.2.el7.x86_64 # 1 SMP Tue Sep 12 22:26:13 UTC 2017 x86_64 x86_64 x86_64 GNU / Linux

In the VM that appears the error is like this:

# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)

# uname -a
Linux s.domain.local 3.10.0-693.11.6.el7.x86_64 # 1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64 x86_64 x86_64 GNU / Linux

Are both VMs not x64?
Any other tips?

User avatar
avij
Forum Moderator
Posts: 2679
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Help resolve packet dependency

Post by avij » 2018/01/16 18:37:50

Oh well, one of those installation scripts that try to be clever but fail at it..

Looks like the dependencies would get installed with yum install glibc.i686 compat-libstdc++-33.i686

After you have installed those, try running that installations script again.

ricardo.claus
Posts: 49
Joined: 2016/07/04 12:46:08

Re: Help resolve packet dependency

Post by ricardo.claus » 2018/01/16 18:42:55

avij wrote:Oh well, one of those installation scripts that try to be clever but fail at it..

Looks like the dependencies would get installed with yum install glibc.i686 compat-libstdc++-33.i686

After you have installed those, try running that installations script again.

Dear Avij, your tip was perfect.

Performed the installation:
# yum install glibc.i686 compat-libstdc++-33.i686

Problem solved.
Thank you!

Post Reply