pcs cluster auth|setup issue Centos 7

General support questions
Post Reply
xg6402
Posts: 1
Joined: 2018/02/08 17:13:22

pcs cluster auth|setup issue Centos 7

Post by xg6402 » 2018/02/09 17:15:49

hi, i'm very new to centos7 cluster, I installed OS and cluster pkgs on top of vsphere as virtual systems, upgraded OS, tested network connection and everything looks fine. But after start pcsd on all 3 nodes. pcs cluster auth|setup has issue. Here is log from node1 where i issued pcs command:
[root@node1 pcsd]# tail pcsd.log
I, [2018-02-09T12:11:45.416273 #3285] INFO -- : Return Value: 1
::ffff:127.0.0.1 - - [09/Feb/2018:12:11:45 -0500] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551 0.0243
::ffff:127.0.0.1 - - [09/Feb/2018:12:11:45 -0500] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551 0.0245
localhost - - [09/Feb/2018:12:11:45 EST] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551
- -> /remote/get_configs?cluster_name=mycluster
I, [2018-02-09T12:11:45.423390 #3285] INFO -- : Return Value: 1
::ffff:127.0.0.1 - - [09/Feb/2018:12:11:45 -0500] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551 0.0419
::ffff:127.0.0.1 - - [09/Feb/2018:12:11:45 -0500] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551 0.0423
localhost - - [09/Feb/2018:12:11:45 EST] "GET /remote/get_configs?cluster_name=mycluster HTTP/1.1" 200 551
- -> /remote/get_configs?cluster_name=mycluster

Looks like it goes nowhere, when i checked node2,3, pcsd.log showed no such connection though on node1 pcs command all showed as "success". Did i miss something here? Appreciate any help on this.

xg

hunter86_bg
Posts: 1213
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: pcs cluster auth|setup issue Centos 7

Post by hunter86_bg » 2018/02/10 07:10:46

Set the firewall to allow access

Code: Select all

firewall-cmd --add-service=high-availability --permanent && firewall-cmd --reload
Start and enable the pcs daemon(on ALL nodes)

Code: Select all

systemctl enable --now pcsd.service
Change the password of the hacluster user

Code: Select all

echo "somepass" | passwd --stdin hacluster
Check you have DNS records for all nodes (A/AAAA and PRT), or define all nodes in "/etc/hosts"
Then try again with

Code: Select all

pcs cluster auth node1 node2 node...n
and then with

Code: Select all

pcs cluster setup ...

Post Reply