Trouble disabling ctrl-alt-del

General support questions
Post Reply
nelm
Posts: 5
Joined: 2018/04/11 16:16:47

Trouble disabling ctrl-alt-del

Post by nelm » 2018/04/16 17:31:26

Hello,

I'm running centos 7.4 and I looked the help in this thread to disable ctrl-alt-delon the console.

viewtopic.php?f=47&t=53969&hilit=disable+ctrl+alt+del :

Code: Select all

systemctl mask ctrl-alt-del.target
systemctl daemon-reload

ls -l /etc/systemd/system/ctrl-alt-del.target 
lrwxrwxrwx. 1 root root 9 Apr 10 16:03 /etc/systemd/system/ctrl-alt-del.target -> /dev/null
If I switch to the console and press ctrl-alt-del once it appears to be disalbed. However, if i keep pressing ctrl-alt-delete (5-ish times) the system reboots. Any ideas why?

desertcat
Posts: 434
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: Trouble disabling ctrl-alt-del

Post by desertcat » 2018/04/16 20:23:31

nelm wrote:Hello,

I'm running centos 7.4 and I looked the help in this thread to disable ctrl-alt-delon the console.

viewtopic.php?f=47&t=53969&hilit=disable+ctrl+alt+del :

Code: Select all

systemctl mask ctrl-alt-del.target
systemctl daemon-reload

ls -l /etc/systemd/system/ctrl-alt-del.target 
lrwxrwxrwx. 1 root root 9 Apr 10 16:03 /etc/systemd/system/ctrl-alt-del.target -> /dev/null
If I switch to the console and press ctrl-alt-del once it appears to be disalbed. However, if i keep pressing ctrl-alt-delete (5-ish times) the system reboots. Any ideas why?
OK you are too late for April Fools Day. Ctl-Alt-Del -- aka the "Three Finger Salute" -- is there to reboot the machine, it is useful when for some strange reason you need to reboot the machine -- freeze, no mouse, a process that can't be killed, etc. -- it is the alternative to a "hard re-boot" ie killing the power then rebooting the machine. The "Three Finger Salute" has been around at least since the days of DOS, and possibly before. It is there to get you out of a BAD situation, without having to resort to a hard reboot. I can think of no programs that do not recognize that key sequence as a signal to reboot the machine. As to your question the reason if you keep pressing that combination is that it is an on/off sequence: One time you turn it off, the next time you turn it back on, etc. If you keep hitting that sequence the machine interprets the action as an intent to reboot the machine. In this the machine must be smarter than you are.

nelm
Posts: 5
Joined: 2018/04/11 16:16:47

Re: Trouble disabling ctrl-alt-del

Post by nelm » 2018/04/16 21:25:00

Thanks for the info. I understand why you would generally want it enabled, but I'm implementing RHEL STIGs for goverment use and one of the requirements is to disable ctrl-alt-del. The disabling instructions worked for gnome, but not the console.
V-71993 - The x86 Ctrl-Alt-Delete key sequence must be disabled. - RHEL-07-020230
Severity

High

Description

A locally logged-on user who presses Ctrl-Alt-Delete, when at the console, can reboot the system. If accidentally pressed, as could happen in the case of a mixed OS environment, this can create the risk of short-term loss of availability of systems due to unintentional reboot. In the GNOME graphical environment, risk of unintentional reboot from the Ctrl-Alt-Delete sequence is reduced because the user will be prompted before any action is taken.

hunter86_bg
Posts: 1327
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: Trouble disabling ctrl-alt-del

Post by hunter86_bg » 2018/04/17 04:01:17

As per Red Hat Solutions there is a raised bugzilla, but it seems private.

So, you have done anything you can.

Post Reply