conflicts error while installing phpmyadmin

General support questions
Post Reply
nexgen
Posts: 1
Joined: 2018/04/23 03:51:24

conflicts error while installing phpmyadmin

Post by nexgen » 2018/04/23 03:55:31

Please kindly someone help me on this error. I'm trying to install phpmyadmin and I get below conflicts error.
[root@server80188 ~]# yum -y update
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
* base: mirrors.aliyun.com
* epel: mirror.smartmedia.net.id
* extras: mirrors.aliyun.com
* remi-safe: mirrors.thzhost.com
* updates: mirrors.aliyun.com
* webtatic: sp.repo.webtatic.com
No packages marked for update
[root@server80188 ~]# yum -y install phpmyadmin
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
* base: mirrors.aliyun.com
* epel: mirror.smartmedia.net.id
* extras: mirrors.aliyun.com
* remi-safe: mirrors.thzhost.com
* updates: mirrors.aliyun.com
* webtatic: sp.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.4.15.10-2.el7 will be installed
--> Processing Dependency: php(language) >= 5.3.7 for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-gd >= 5.3.7 for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-mbstring >= 5.3.7 for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-mysqli >= 5.3.7 for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-bz2 for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-ctype for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-curl for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-date for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-filter for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-iconv for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-json for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-libxml for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-openssl for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-pcre for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-session for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-simplexml for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-spl for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-tcpdf for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-xmlwriter for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-zip for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Processing Dependency: php-zlib for package: phpMyAdmin-4.4.15.10-2.el7.noarch
--> Running transaction check
---> Package php-php-gettext.noarch 0:1.0.12-1.el7 will be installed
---> Package php-tcpdf.noarch 0:6.2.13-1.el7 will be installed
--> Processing Dependency: /usr/bin/php for package: php-tcpdf-6.2.13-1.el7.noarch
--> Processing Dependency: php-bcmath for package: php-tcpdf-6.2.13-1.el7.noarch
--> Processing Dependency: php-composer(fedora/autoloader) for package: php-tcpdf-6.2.13-1.el7.noarch
--> Processing Dependency: php-posix for package: php-tcpdf-6.2.13-1.el7.noarch
--> Processing Dependency: php-tidy for package: php-tcpdf-6.2.13-1.el7.noarch
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.13-1.el7 will be installed
--> Processing Dependency: dejavu-sans-fonts for package: php-tcpdf-dejavu-sans-fonts-6.2.13-1.el7.noarch
---> Package php72w-common.x86_64 0:7.2.4-1.w7 will be installed
---> Package php72w-gd.x86_64 0:7.2.4-1.w7 will be installed
---> Package php72w-mbstring.x86_64 0:7.2.4-1.w7 will be installed
---> Package php72w-mysql.x86_64 0:7.2.4-1.w7 will be installed
--> Processing Dependency: php72w-pdo(x86-64) for package: php72w-mysql-7.2.4-1.w7.x86_64
---> Package php72w-xml.x86_64 0:7.2.4-1.w7 will be installed
--> Running transaction check
---> Package dejavu-sans-fonts.noarch 0:2.33-6.el7 will be installed
--> Processing Dependency: dejavu-fonts-common = 2.33-6.el7 for package: dejavu-sans-fonts-2.33-6.el7.noarch
---> Package php-bcmath.x86_64 0:5.4.16-43.el7_4.1 will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.16-43.el7_4.1 for package: php-bcmath-5.4.16-43.el7_4.1.x86_64
---> Package php-cli.x86_64 0:5.4.16-43.el7_4.1 will be installed
---> Package php-fedora-autoloader.noarch 0:1.0.0-1.el7 will be installed
---> Package php-process.x86_64 0:5.4.16-43.el7_4.1 will be installed
---> Package php-tidy.x86_64 0:5.4.16-7.el7 will be installed
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy-5.4.16-7.el7.x86_64
---> Package php72w-pdo.x86_64 0:7.2.4-1.w7 will be installed
--> Running transaction check
---> Package compat-libtidy.x86_64 0:0.99.0-37.20091203.el7 will be installed
---> Package dejavu-fonts-common.noarch 0:2.33-6.el7 will be installed
--> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common-2.33-6.el7.noarch
---> Package php-common.x86_64 0:5.4.16-43.el7_4.1 will be installed
--> Running transaction check
---> Package fontpackages-filesystem.noarch 0:1.44-8.el7 will be installed
--> Processing Conflict: php72w-common-7.2.4-1.w7.x86_64 conflicts php-common < 7.2
--> Finished Dependency Resolution
Error: php72w-common conflicts with php-common-5.4.16-43.el7_4.1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I tried removing all previously installed php and all packages. but still getting conflicts error.

mghe
Posts: 698
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: conflicts error while installing phpmyadmin

Post by mghe » 2018/04/23 05:40:47

Good morning,

Dependencies for phpMyAdmin are php and some other pakages. So if You install other version of php ( override dist version ) best way is download it from author website.

User avatar
TrevorH
Forum Moderator
Posts: 23203
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: conflicts error while installing phpmyadmin

Post by TrevorH » 2018/04/23 06:08:58

We do not recommend use of the webtatic repo. For a start, you also have remi-safe installed so it's very likely that that will conflict with webtatic. Get shot of one of them. Remi has a page about how to install his packages, you should read it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
remirepo
Posts: 289
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: conflicts error while installing phpmyadmin

Post by remirepo » 2018/04/23 07:26:42

Don't expect phpMyAdmin 4.4 from EPEL to work with any recent versions (7.x) of PHP.


Solution 1 : disable webtatic and use PHP from base repository

Solution 2 : don't use phpMyAdmin from EPEL

Solution 3 : use a repository which provides a consistent PHP stack,including phpMyAdmin (4.8)

This, of course depends of the PHP version your need.
Remi's Repository - Forum - Blog

Post Reply