The Value of a Good Backup

General support questions
Post Reply
Posts: 559
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

The Value of a Good Backup

Post by desertcat » 2018/05/12 10:15:53

I have a mixed review of CentOS 7.5.


Well the NEW 500 GB HDD came in and I installed it into Jaguar aka the "Trashcan Monster". I did a complete install from the ground up and it went off without a hitch, though I think at one point I had to run --skip-broken. I then had to undertake the hours long process of configuring the machine and the process still has not been finished. It is this process I had hoped to avoid on my workstation, and the reason I would prefer to simply roll over the machine via yum update.

The BAD:

My buddy ran yum update and his machine rolled over but upon coming up he was greeted with a BLACK SCREEN, like me he was using sddm which seems to now be BROKEN. After hitting Ctl+Alt+F2 he reversed the process and reinstalled gdm, the computer gave him a creepy crawly on the bottom of the screen and he was lead to his login screen.


Taking heart from my buddy's experience I ran yum update, I too ended up with a BLACK SCREEN. I hit Ctl+Alt+F2 and ran the systemclt commands to re-install gdm only I ended back at a prompt, not at a Login Screen. I rebooted my machine still no login screen. I tried to login as a user and was greeted by a minimal GUI, but without a panel or able to gain access to a terminal. I tried to install and re-install both sddm and then gdm, still no login screen. A constant was I would get the same purple and white Creepy Crawly and a ERROR Message about something already in use. I got a little more desperate. And did a limited fresh install: leaving /usr, /home, /boot, /backup, /vm4 as is, but re-formatted /, /var, /tmp, and swap. This got me back to a login screen, but discovered that /usr seems to have lost many of it programs, many of the customizations were also lost, and something seemed a bit "off" on my screen saver that had a herket jerkey quality, which is NOT a cool thing for an epileptic. I had also lost my network. We re-installed from my /usr backup. That actually *did* work, but I was still minus my network, and soon discovered that all my other users while seen to still exist, were in fact no longer as were the other GUI's I had installed -- all MIA!! I threw in the towel. I went for the ULTIMATE restore: I restored the ENTIRE disk from a backup I made on April 18th. I booted a LIVE KDE version of CentOS 7.3 and after several hours had restored my machine back to CentOS 7.4 from which I am currently working, My BACKUP saved me. This was the ULTIMATE test.


For the time being I am back in the land of CentOS 7.4 trying to figure out WHAT WENT WRONG!!!

A) Like my buddy I got an ERROR MESSAGE and I had run -- skip-broken. Most of the errors were in the "trinity" repo. I could try to disable this repo then run a test yum update then back out when it reaches the "Do you want to install y/N?

B) Like my buddy I had the purple and white "Creepy Crawly" on the bottom of the screen.

C) Unlike my buddy I got an ERROR message that flashed by that said something that something was already in use and could not be allocated or something to that effect.

D) IF this a problem of the Display Manager sddm which clearly seems to now be toast on my NEXT ATTEMPT probably within the next week or two I might FIRST try to disable sddm and re-enable gdm BEFORE I try to run yum update, the idea being since gdm is ALREADY enabled the system does not throw a hissy fit and brings me straight to a login screen. SECOND I might for a very brief time disable SELinux in case this is software conflict during the rollover and after the rollover turn SELinux back on to ENFORCING mode. THIRD Disable the "Trinity" Repo and thereby avoid the necessity of running --skip-broken FOURTH in one or two weeks maybe some of the repos will now be back on line in CentOS 7.5 mode.

CONCLUSION: While being back in CentOS 7.4 is less than optimal, it sure beats where I was a few hours ago with a highly crippled machine. Once you have have rolled over / installed 7.5 and it is working DO a backup of the entire disk; also DO a backup of the entire disk just before 7.6 comes out. That backup saved my butt this time!!!

Post Reply