SDDM: Worked in CentOS 7.4; Does Not Work in 7.5

General support questions
Post Reply
Posts: 549
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

SDDM: Worked in CentOS 7.4; Does Not Work in 7.5

Post by desertcat » 2018/05/16 11:04:40

I'm wondering if anyone has had problems with sddm?? When gdm went off the rails in early '17 I found I could get around the problem by using sddm. The second 7.5 is introduced I can no longer start sddm, or lightdm. I'm wondering if someone, anyone, who uses an alternative display manager other than gdm is having problems getting the alternate display manager to work. I'm particularly interested in sddm and if you had the problem but fixed it, how did you do it?? The way I got sddm or gdm enabled [ but which no longer works for enabling sddm and starting it] was:

systemctl stop display-manager
systemctl disable [gdm / sddm]
systemctl enable [sddm / gdm ]
systemctl start display-manager

Having to rely ONLY on gdm without having an alternative is asking for trouble just in cast RH manages to break it again leading to a runaway process. SDDM was a good alternative to gdm and I preferred it over gdm, now within one point release I can no longer have it start up. That's flaky.

Post Reply