You could try using --skip-broken to work around the problem

General support questions
Post Reply
mehmetozbakir
Posts: 1
Joined: 2018/06/16 09:22:44

You could try using --skip-broken to work around the problem

Post by mehmetozbakir » 2018/06/16 09:26:06

Hello Dear ,
Couple day's I've tried everything to install pagespeed on centos 7 but It's giving that error ...


[root@vmi188732 pagespeed]# yum install pagespeed
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
epel/x86_64/metalink | 31 kB 00:00
Excluding mirror: mirror.fra10.de.leaseweb.net
* base: asi-fs-m.contabo.net
Excluding mirror: mirror.de.leaseweb.net
Excluding mirror: mirror.nl.leaseweb.net
* epel: mirror.imt-systems.com
Excluding mirror: mirror.fra10.de.leaseweb.net
* extras: ftp.plusline.de
Excluding mirror: mirror.fra10.de.leaseweb.net
* updates: asi-fs-m.contabo.net
base | 3.6 kB 00:00
epel | 3.2 kB 00:00
extras | 3.4 kB 00:00
litespeed | 3.6 kB 00:00
litespeed-update | 3.6 kB 00:00
mariadb | 2.9 kB 00:00
powerdns-auth-master | 2.9 kB 00:00
updates | 3.4 kB 00:00
(1/13): base/7/x86_64/group_gz | 166 kB 00:00
(2/13): epel/x86_64/updateinfo | 928 kB 00:00
(3/13): epel/x86_64/group_gz | 88 kB 00:00
(4/13): extras/7/x86_64/primary_db | 149 kB 00:00
(5/13): base/7/x86_64/primary_db | 5.9 MB 00:00
(6/13): litespeed/7/x86_64/group_gz | 855 B 00:00
(7/13): epel/x86_64/primary | 3.5 MB 00:00
(8/13): litespeed-update/7/x86_64/group_gz | 855 B 00:00
(9/13): powerdns-auth-master/7/x86_64/primary_db | 106 kB 00:00
(10/13): updates/7/x86_64/primary_db | 2.7 MB 00:00
(11/13): mariadb/primary_db | 35 kB 00:00
(12/13): litespeed-update/7/x86_64/primary_db | 168 kB 00:01
(13/13): litespeed/7/x86_64/primary_db | 828 kB 00:02
epel 12584/12584
112 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package pagespeed.x86_64 0:1.4.17-1.el7.centos will be installed
--> Processing Dependency: openlitespeed14 >= 1.4.13 for package: pagespeed-1.4.17-1.el7.centos.x86_64
Package openlitespeed14-1.4.17-2.el7.centos.x86_64 is obsoleted by openlitespeed-1.4.32-8.el7.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: pagespeed-1.4.17-1.el7.centos.x86_64 (litespeed)
Requires: openlitespeed14 >= 1.4.13
Available: openlitespeed14-1.4.13-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.13-1.el7.centos
Available: openlitespeed14-1.4.14-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.14-1.el7.centos
Available: openlitespeed14-1.4.15-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.15-1.el7.centos
Available: openlitespeed14-1.4.16-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.16-1.el7.centos
Available: openlitespeed14-1.4.17-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.17-1.el7.centos
Available: openlitespeed14-1.4.17-2.el7.centos.x86_64 (litespeed-update)
openlitespeed14 = 1.4.17-2.el7.centos
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


And Also When I try Make command while giving

[root@vmi188732 ~]# cd ols/src/modules/pagespeed
[root@vmi188732 pagespeed]# make
f77 Makefile.f -o Makefile
make: f77: Command not found
make: *** No targets specified and no makefile found. Stop.


Really I will be crazy please some one help meeeee

User avatar
TrevorH
Forum Moderator
Posts: 23042
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: You could try using --skip-broken to work around the problem

Post by TrevorH » 2018/06/16 11:25:46

You need to ask the people that run that "litespeeed" repo as they have broken it.

Nothing that we supply provides an 'f77' executable on CentOS 7.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

desertcat
Posts: 403
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: You could try using --skip-broken to work around the problem

Post by desertcat » 2018/06/18 21:27:25

mehmetozbakir wrote:
2018/06/16 09:26:06
Hello Dear ,
Couple day's I've tried everything to install pagespeed on centos 7 but It's giving that error ...


[root@vmi188732 pagespeed]# yum install pagespeed
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
epel/x86_64/metalink | 31 kB 00:00
Excluding mirror: mirror.fra10.de.leaseweb.net
* base: asi-fs-m.contabo.net
Excluding mirror: mirror.de.leaseweb.net
Excluding mirror: mirror.nl.leaseweb.net
* epel: mirror.imt-systems.com
Excluding mirror: mirror.fra10.de.leaseweb.net
* extras: ftp.plusline.de
Excluding mirror: mirror.fra10.de.leaseweb.net
* updates: asi-fs-m.contabo.net
base | 3.6 kB 00:00
epel | 3.2 kB 00:00
extras | 3.4 kB 00:00
litespeed | 3.6 kB 00:00
litespeed-update | 3.6 kB 00:00
mariadb | 2.9 kB 00:00
powerdns-auth-master | 2.9 kB 00:00
updates | 3.4 kB 00:00
(1/13): base/7/x86_64/group_gz | 166 kB 00:00
(2/13): epel/x86_64/updateinfo | 928 kB 00:00
(3/13): epel/x86_64/group_gz | 88 kB 00:00
(4/13): extras/7/x86_64/primary_db | 149 kB 00:00
(5/13): base/7/x86_64/primary_db | 5.9 MB 00:00
(6/13): litespeed/7/x86_64/group_gz | 855 B 00:00
(7/13): epel/x86_64/primary | 3.5 MB 00:00
(8/13): litespeed-update/7/x86_64/group_gz | 855 B 00:00
(9/13): powerdns-auth-master/7/x86_64/primary_db | 106 kB 00:00
(10/13): updates/7/x86_64/primary_db | 2.7 MB 00:00
(11/13): mariadb/primary_db | 35 kB 00:00
(12/13): litespeed-update/7/x86_64/primary_db | 168 kB 00:01
(13/13): litespeed/7/x86_64/primary_db | 828 kB 00:02
epel 12584/12584
112 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package pagespeed.x86_64 0:1.4.17-1.el7.centos will be installed
--> Processing Dependency: openlitespeed14 >= 1.4.13 for package: pagespeed-1.4.17-1.el7.centos.x86_64
Package openlitespeed14-1.4.17-2.el7.centos.x86_64 is obsoleted by openlitespeed-1.4.32-8.el7.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: pagespeed-1.4.17-1.el7.centos.x86_64 (litespeed)
Requires: openlitespeed14 >= 1.4.13
Available: openlitespeed14-1.4.13-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.13-1.el7.centos
Available: openlitespeed14-1.4.14-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.14-1.el7.centos
Available: openlitespeed14-1.4.15-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.15-1.el7.centos
Available: openlitespeed14-1.4.16-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.16-1.el7.centos
Available: openlitespeed14-1.4.17-1.el7.centos.x86_64 (litespeed)
openlitespeed14 = 1.4.17-1.el7.centos
Available: openlitespeed14-1.4.17-2.el7.centos.x86_64 (litespeed-update)
openlitespeed14 = 1.4.17-2.el7.centos
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


And Also When I try Make command while giving

[root@vmi188732 ~]# cd ols/src/modules/pagespeed
[root@vmi188732 pagespeed]# make
f77 Makefile.f -o Makefile
make: f77: Command not found
make: *** No targets specified and no makefile found. Stop.


Really I will be crazy please some one help meeeee
There are a couple of things you can do:

1) run yum remove [package_name] EXAMPLE: yum remove pagespeed-1.4.17-1.el7.centos.x86_64
2) run yum update --exclude=[package_name] EXAMPLE: yum update --exclude=pagespeed-1.4.17-1.el7.centos.x86_64
caveat emptor you would have to have a string of --exclude=[package_name] -- exclude=[package_name_2]... indeed one for each package.
3) disable the repo. To make sure it would not be a problem I went to /etc/yum.repos.d copied the offending repo to some place safe, then deleted the offending repo from /etc/yum.repos.d then ran yum update. If at some time in the future there is a fix to the offending repo I just need to copy it back into /etc/yum.repos.d.

desertcat
Posts: 403
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: You could try using --skip-broken to work around the problem

Post by desertcat » 2018/06/18 21:53:53

mehmetozbakir wrote:
2018/06/16 09:26:06
Hello Dear ,
Couple day's I've tried everything to install pagespeed on centos 7 but It's giving that error ...
It is possible either 1) you have a conflicting package of that name in which case you need to remove the old package, though WARNING: THIS COULD BE DANGEROUS AS OTHER PACKAGES THAT RELY ON THAT PACKAGE WILL BREAK. In which case you are screwed. If you go this route be VERY, VERY CAREFUL. If you decide to remove a package, and it says erasing 1 package then you are probably safe, IF it says it ways to erase 20+ packages answer NO!!

2) Is pagespeed available for CentOS7??? There are a lot of groovy packages out there I would love to try but are simply not supported by CentOS 7.

3) Some times the package is available for CentOS 7 but the version available was written in the Neolithic Era. Go to the website that makes the package and check what their current release is and then check it against the one available for CentOS 7. I had this recently happen. I found a really groovy package and found it was available for CentOS 7, installed it no problem, but found it did not work. Went to the website and they had released version 2.5, and the one available for CentOS 7 was version 0.95.

4) Find a similar package as the one you are trying to install.

Post Reply