Can't disable Gnome wacom plugin anymore (CentOS 7.5, Gnome 3.24)

General support questions
Post Reply
lee11lee
Posts: 2
Joined: 2017/01/24 16:31:52

Can't disable Gnome wacom plugin anymore (CentOS 7.5, Gnome 3.24)

Post by lee11lee » 2018/06/19 08:18:43

Hi,

I'm using CentOS 7.5 with Gnome 3.24.

I'm trying to set my Wacom Buttons AbsWheelUp and AbsWheelDown to scroll up and down.
In the past on Gnome version 3.22 (CentOS 7.3) I could do that via:

disabling the wacom plugin (otherwise you can not map mouse actions to the pad) via:

Code: Select all

gsettings set org.gnome.settings-daemon.plugins.gsdwacom active false
then hardcoding the two buttons via:

Code: Select all

xsetwacom set "Wacom Intuos4 8x13 pad" AbsWheelDown 5
xsetwacom set "Wacom Intuos4 8x13 pad" AbsWheelUp 4
Now in the new gnome version 3.25.4 the setting to disable the wacom plugin is not there. The only settings I have in the plugins folder are:

Code: Select all

$ gsettings list-children org.gnome.settings-daemon.plugins
housekeeping   org.gnome.settings-daemon.plugins.housekeeping
power          org.gnome.settings-daemon.plugins.power
color          org.gnome.settings-daemon.plugins.color
media-keys     org.gnome.settings-daemon.plugins.media-keys
xsettings      org.gnome.settings-daemon.plugins.xsettings
I also tried searching the dconf for Wacom settings, but with no results.

As I understand, there has been a major change to the wacom implementation in gnome 3.24..

How can I still set the buttons to scrolling and bypass the gnome wacom plugin?

Thank you, any help would be greatly appreciated!

lee

Post Reply